Read the docs
TI-2026-66813 Aliases GHSA-w5pp-99ch-qj29

go-git: Malformed Git object data may cause panics or resource exhaustion

Priority LOW 38CWE-400Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400.

Summary

### Impact Several denial-of-service issues were identified in `go-git` when parsing maliciously crafted Git repository data. An attacker may craft a malicious `.pack`, `.idx` or loose objects that causes an application using an affected version of `go-git` to panic or consume excessive resources. This can lead to denial of service in applications that use `go-git` to clone, fetch, open, or otherwise process untrusted repositories or Git object data. Exploitation requires the ability to alter read-only files such as `.pack` or `.idx` from the local repository's `.git/objects/pack/` directory. Alternatively, the user would need to be interacting with a malicious remote server, which is not recommended and exposes users to a broader class of security risks beyond this issue. ### Patches Users should upgrade to a patched version in order to mitigate this vulnerability. Versions prior to `v5` are likely to be affected, users are recommended to upgrade to a supported `go-git` version. ### Credits go-git thanks @kodareef5, @AyushParkara and @N0zoM1z0 for reporting this in four separate reports. 🙇

Why it matters now

Fix Fixed github.com/go-git/go-git/v5 (Go): 5.19.1github.com/go-git/go-git/v6 (Go): 6.0.0-alpha.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—github.com/go-git/go-git/v5 (Go)before 5.19.15.19.1Patch availableGHSA-w5pp-99ch-qj29
—github.com/go-git/go-git/v6 (Go)before 6.0.0-alpha.46.0.0-alpha.4Patch availableGHSA-w5pp-99ch-qj29
  • github.com/go-git/go-git/v5 (Go) Vendor— Affected before 5.19.1 Fixed in 5.19.1 Patch available GHSA-w5pp-99ch-qj29
  • github.com/go-git/go-git/v6 (Go) Vendor— Affected before 6.0.0-alpha.4 Fixed in 6.0.0-alpha.4 Patch available GHSA-w5pp-99ch-qj29

Remediation

  • Fix · GHSA-w5pp-99ch-qj29 github.com/go-git/go-git/v5 (Go) Fixed in 5.19.1 Advisory →
  • Fix · GHSA-w5pp-99ch-qj29 github.com/go-git/go-git/v6 (Go) Fixed in 6.0.0-alpha.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-w5pp-99ch-qj29

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences