Read the docs
TI-2026-66824 Aliases GHSA-jpvj-wpmj-h7rv

Supply chain compromise via malicious @cap-js/openapi

Priority LOW 38CWE-506Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-506.

Summary

### Impact On May 19, 2026, a compromised version of @cap-js/[email protected] was published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. ### Patches Upgrade to @cap-js/openapi >= 1.4.2 If the compromised version was ever installed, rotate all affected credentials. ### Workarounds No workarounds. ### References - [SAP Note 3747787](https://me.sap.com/notes/3747787) - [Developer FAQ](https://www.sap.com/documents/2026/05/8203a8b9-4d7f-0010-bca6-c68f7e60039b.html)

Why it matters now

Fix Fixed @cap-js/openapi (npm): 1.4.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@cap-js/openapi (npm)1.4.1 to before 1.4.21.4.2Patch availableGHSA-jpvj-wpmj-h7rv
  • @cap-js/openapi (npm) Vendor— Affected 1.4.1 to before 1.4.2 Fixed in 1.4.2 Patch available GHSA-jpvj-wpmj-h7rv

Remediation

  • Fix · GHSA-jpvj-wpmj-h7rv @cap-js/openapi (npm) Fixed in 1.4.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-jpvj-wpmj-h7rv

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences