Vulnerable OpenSSL included in cryptography wheels
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20260609.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | cryptography (PyPI) | 0.5.0 to before 48.0.1 | 48.0.1 | Patch available | GHSA-537c-gmf6-5ccf |
- cryptography (PyPI) Vendor— Affected 0.5.0 to before 48.0.1 Fixed in 48.0.1 Patch available GHSA-537c-gmf6-5ccf
Remediation
- Fix · GHSA-537c-gmf6-5ccf cryptography (PyPI) Fixed in 48.0.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-537c-gmf6-5ccf
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences