Read the docs
TI-2026-66843 Aliases GHSA-hv7x-3x78-gx53

n8n: Wrong OAuth Scope On Evaluations Test Run Creation Endpoint

Priority LOW 38CWE-284Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-284.

Summary

## Impact The `POST /workflows/{workflowId}/test-runs/new` endpoint authorized access using `workflow:read` rather than `workflow:execute`. An authenticated user with read-only access to a workflow could trigger a real evaluation test run, causing the workflow to execute via the internal workflow runner. This could result in unintended outbound API calls, data mutations, or other side effects in downstream systems connected to the workflow. This issue primarily affects instances where the Evaluations feature is in use and where users may have `workflow:read` access without `workflow:execute` access, such as deployments using RBAC project roles. ## Patches The issue has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict workflow access to fully trusted users only. - Audit project role assignments and limit `workflow:read` access on sensitive workflows to users who should also be permitted to execute them. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Fix Fixed n8n (npm): 1.123.55, 2.26.2, 2.25.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—n8n (npm)before 1.123.551.123.55Patch availableGHSA-hv7x-3x78-gx53
—n8n (npm)2.26.0 to before 2.26.22.26.2Patch availableGHSA-hv7x-3x78-gx53
—n8n (npm)2.0.0-rc.0 to before 2.25.72.25.7Patch availableGHSA-hv7x-3x78-gx53
  • n8n (npm) Vendor— Affected before 1.123.55 Fixed in 1.123.55 Patch available GHSA-hv7x-3x78-gx53
  • n8n (npm) Vendor— Affected 2.26.0 to before 2.26.2 Fixed in 2.26.2 Patch available GHSA-hv7x-3x78-gx53
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.25.7 Fixed in 2.25.7 Patch available GHSA-hv7x-3x78-gx53

Remediation

  • Fix · GHSA-hv7x-3x78-gx53 n8n (npm) Fixed in 1.123.55 Advisory →
  • Fix · GHSA-hv7x-3x78-gx53 n8n (npm) Fixed in 2.26.2 Advisory →
  • Fix · GHSA-hv7x-3x78-gx53 n8n (npm) Fixed in 2.25.7 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-hv7x-3x78-gx53

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences