Read the docs
TI-2026-66847 Aliases GHSA-jwm3-qcfw-c5pp

n8n: Python Code Node AST Validator Bypass

Priority LOW 38CWE-693Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-693.

Summary

## Impact An authenticated user with permission to create or modify workflows containing a Python Code node could bypass the AST security validator and access the task executor module namespace. On self-hosted instances where `N8N_BLOCK_RUNNER_ENV_ACCESS=false` is set, this extended to disclosure of environment variables accessible to the task runner process. This issue only affects instances where the Python Task Runner is enabled and `N8N_BLOCK_RUNNER_ENV_ACCESS=true`. ## Patches The issue has been fixed in n8n versions 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the Python Code node by adding `n8n-nodes-base.code` to the `NODES_EXCLUDE` environment variable, or disable the Python Task Runner entirely. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Fix Fixed n8n (npm): 2.26.2, 2.25.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—n8n (npm)2.26.0 to before 2.26.22.26.2Patch availableGHSA-jwm3-qcfw-c5pp
—n8n (npm)before 2.25.72.25.7Patch availableGHSA-jwm3-qcfw-c5pp
  • n8n (npm) Vendor— Affected 2.26.0 to before 2.26.2 Fixed in 2.26.2 Patch available GHSA-jwm3-qcfw-c5pp
  • n8n (npm) Vendor— Affected before 2.25.7 Fixed in 2.25.7 Patch available GHSA-jwm3-qcfw-c5pp

Remediation

  • Fix · GHSA-jwm3-qcfw-c5pp n8n (npm) Fixed in 2.26.2 Advisory →
  • Fix · GHSA-jwm3-qcfw-c5pp n8n (npm) Fixed in 2.25.7 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-jwm3-qcfw-c5pp

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences