Read the docs
TI-2026-66851 Aliases GHSA-664h-gpgq-h6xx

n8n: Wrong OAuth Scope on Evaluation Test Runs Endpoints

Priority LOW 38CWE-863Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-863.

Summary

## Impact Three mutating endpoints in the evaluation test runs controller authorized state-changing actions using `workflow:read` instead of the action-appropriate `workflow:execute` scope. An authenticated user with `project:viewer` role on a project could start new evaluation test runs, cancel in-flight runs, and delete run records for workflows they only had read access to. This issue only affects instances with Advanced Permissions (Enterprise/Cloud) where projects and viewer roles are in use. ## Patches The issue has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict project membership to fully trusted users only. - Avoid granting viewer access to projects containing sensitive workflows. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Fix Fixed n8n (npm): 1.123.55, 2.26.2, 2.25.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—n8n (npm)before 1.123.551.123.55Patch availableGHSA-664h-gpgq-h6xx
—n8n (npm)2.26.0 to before 2.26.22.26.2Patch availableGHSA-664h-gpgq-h6xx
—n8n (npm)2.0.0-rc.0 to before 2.25.72.25.7Patch availableGHSA-664h-gpgq-h6xx
  • n8n (npm) Vendor— Affected before 1.123.55 Fixed in 1.123.55 Patch available GHSA-664h-gpgq-h6xx
  • n8n (npm) Vendor— Affected 2.26.0 to before 2.26.2 Fixed in 2.26.2 Patch available GHSA-664h-gpgq-h6xx
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.25.7 Fixed in 2.25.7 Patch available GHSA-664h-gpgq-h6xx

Remediation

  • Fix · GHSA-664h-gpgq-h6xx n8n (npm) Fixed in 1.123.55 Advisory →
  • Fix · GHSA-664h-gpgq-h6xx n8n (npm) Fixed in 2.26.2 Advisory →
  • Fix · GHSA-664h-gpgq-h6xx n8n (npm) Fixed in 2.25.7 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-664h-gpgq-h6xx

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences