Read the docs
TI-2026-66865 Aliases GHSA-cgxm-vr2f-6fj8

parse-server: Denial of service via exponential-time processing of deeply nested query operators

Priority LOW 38CWE-407Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-407.

Summary

### Impact Parse Server is vulnerable to denial of service. A remote attacker can send a single, small query (~1 KB) containing deeply nested query condition operators. Parse Server processes the nested structure with exponential time complexity, which blocks the Node.js event loop and makes the server unresponsive to all clients for the duration of processing. A single request can occupy the event loop for many seconds, and the request is repeatable. The issue affects the REST API and LiveQuery query handling and is reachable in the default configuration. Exploitation requires only the public application identifier; no user authentication is needed. ### Patches The internal query-traversal helper that previously re-walked nested arrays — causing exponential-time processing of nested `$or`/`$and`/`$nor` operators — was corrected to traverse queries in linear time. Additionally, the optional `requestComplexity.queryDepth` limit was generalized so that nested logical operators are counted even when wrapped inside field-level operators (e.g. `$elemMatch`, `$not`) or plain field names, closing a bypass of the limit on both the REST API and LiveQuery. ### Workarounds There is no complete configuration-only workaround on affected versions. Setting `requestComplexity.queryDepth` to a small positive integer reduces exposure but does not fully prevent the issue, because the limit can be bypassed by nesting the operators inside a field-level operator. Upgrading is strongly recommended.

Why it matters now

Fix Fixed parse-server (npm): 9.9.1-alpha.12, 8.6.82

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—parse-server (npm)9.0.0 to before 9.9.1-alpha.129.9.1-alpha.12Patch availableGHSA-cgxm-vr2f-6fj8
—parse-server (npm)before 8.6.828.6.82Patch availableGHSA-cgxm-vr2f-6fj8
  • parse-server (npm) Vendor— Affected 9.0.0 to before 9.9.1-alpha.12 Fixed in 9.9.1-alpha.12 Patch available GHSA-cgxm-vr2f-6fj8
  • parse-server (npm) Vendor— Affected before 8.6.82 Fixed in 8.6.82 Patch available GHSA-cgxm-vr2f-6fj8

Remediation

  • Fix · GHSA-cgxm-vr2f-6fj8 parse-server (npm) Fixed in 9.9.1-alpha.12 Advisory →
  • Fix · GHSA-cgxm-vr2f-6fj8 parse-server (npm) Fixed in 8.6.82 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-cgxm-vr2f-6fj8

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences