Anki: User scripts in iframes have access to the internal Anki API
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
## Summary Anki's webview-based pages communicate with the Rust backend using an internal localhost API. Anki implements measures to prevent user scripts run in the reviewer/editor from accessing this API (https://github.com/ankitects/anki/pull/3925) but it inadvertently allows access to scripts included via iframes in the editor. While overall only a limited set of API methods are exposed, some such as `getImageForOcclusion` can read arbitrary files. **CWE:** CWE-22 (Path Traversal) **Reporter:** Bankde (Eakasit) ## Affected Products | Ecosystem | Package | Affected Versions | | --------- | ------- | ----------------- | | PyPI | `aqt` | `<= 25.09.3` | ## Impact Any desktop Anki user (Windows, macOS, Linux) who imports an untrusted `.apkg` and views card with an embedded iframe is vulnerable. No special configuration is required. The attacker can read any file accessible to the Anki process and exfiltrate its contents over the network. ## Patches A patch is available in 25.09.4 ## Workarounds - Do not import `.apkg` files from untrusted sources. - Inspect `.apkg` contents (it's a ZIP) for `.html`/`.svg` files with `<script>` tags before importing. - Block unexpected outbound network requests from the Anki process at the firewall level. ## References - Vulnerability report: _Anki arbitrary file read vulnerability (with exfiltration)_ — Bankde (Eakasit) - Affected source: [`qt/aqt/mediasrv.py::_handle_local_file_request`](https://github.com/ankitects/anki/blob/5a9b54e9380c66e26391f0827867d2a728107836/qt/aqt/mediasrv.py#L223) - Related prior CVEs: [CVE-2024-29073](https://nvd.nist.gov/vuln/detail/CVE-2024-29073), [CVE-2024-32484](https://nvd.nist.gov/vuln/detail/CVE-2024-32484), [CVE-2025-62185](https://nvd.nist.gov/vuln/detail/CVE-2025-62185), [CVE-2025-62187](https://nvd.nist.gov/vuln/detail/CVE-2025-62187)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | aqt (PyPI) | before 25.9.4 | 25.9.4 | Patch available | GHSA-cw6h-ffmh-x6vh |
- aqt (PyPI) Vendor— Affected before 25.9.4 Fixed in 25.9.4 Patch available GHSA-cw6h-ffmh-x6vh
Remediation
- Fix · GHSA-cw6h-ffmh-x6vh aqt (PyPI) Fixed in 25.9.4 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-cw6h-ffmh-x6vh
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences