Read the docs
TI-2026-67087 Aliases GHSA-f88m-g3jw-g9cj

sharp inherited vulnerabilities in libvips: CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591

Priority LOW 38CWE-1395Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact A number of vulnerabilities, two rated as "High" severity using CVSSv4, have been discovered and fixed in the upstream libvips dependency. Those processing untrusted input with versions of sharp prior to 0.35.0 are affected. ### Patches #### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest version, currently 0.35.3, which provides libvips 8.18.3. #### Using a globally-installed libvips? Please ensure you are using the latest libvips 8.18.3. ### Workarounds Add the following to your code to prevent sharp from decoding GIF, TIFF and VIPS images. ```js sharp.block({ operation: ["VipsForeignLoadNsgif", "VipsForeignLoadTiff", "VipsForeignLoadVips"] }); ```

Why it matters now

Fix Fixed sharp (npm): 0.35.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—sharp (npm)before 0.35.00.35.0Patch availableGHSA-f88m-g3jw-g9cj
  • sharp (npm) Vendor— Affected before 0.35.0 Fixed in 0.35.0 Patch available GHSA-f88m-g3jw-g9cj

Remediation

  • Fix · GHSA-f88m-g3jw-g9cj sharp (npm) Fixed in 0.35.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-f88m-g3jw-g9cj

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences