n8n: Bypass "Allowed HTTP Request Domains" Credential Restriction in Multiple AI and LLM Nodes
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-863.
Summary
## Impact The credential "Allowed HTTP Request Domains" allowlist was intended to restrict which hosts a credential's secret could be sent to, protecting shared credentials from users who could use but not view them. Several AI/LLM nodes did not enforce this allowlist when a user-supplied base or endpoint URL was set. A low-privileged workflow editor with use-only access to such a shared credential could point one of these nodes at an attacker-controlled host and cause the credential secret to be transmitted there, then reuse it against the underlying service. Only instances where a credential has "Allowed HTTP Request Domains" configured and is shared with non-owner users are affected. ## Patches The issue has been fixed in n8n versions 2.31.5 and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict workflow creation and editing permissions to fully trusted users only. - Restrict credential sharing to fully trusted users only. - Audit credentials with domain restrictions for unexpected sharing relationships. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | n8n (npm) | 2.32.0 to before 2.32.1 | 2.32.1 | Patch available | GHSA-64xh-79j6-r5v8 |
| — | n8n (npm) | before 2.31.5 | 2.31.5 | Patch available | GHSA-64xh-79j6-r5v8 |
- n8n (npm) Vendor— Affected 2.32.0 to before 2.32.1 Fixed in 2.32.1 Patch available GHSA-64xh-79j6-r5v8
- n8n (npm) Vendor— Affected before 2.31.5 Fixed in 2.31.5 Patch available GHSA-64xh-79j6-r5v8
Remediation
- Fix · GHSA-64xh-79j6-r5v8 n8n (npm) Fixed in 2.32.1 Advisory →
- Fix · GHSA-64xh-79j6-r5v8 n8n (npm) Fixed in 2.31.5 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-64xh-79j6-r5v8
References
Other 5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences