Read the docs
TI-2026-67092 Aliases GHSA-rcv6-pvrj-4xcg

n8n: Authenticated code execution in the n8n Git node

Priority LOW 38CWE-78Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-78.

Summary

## Impact Authenticated n8n users with rights to create and execute workflows could achieve code execution on the n8n host. Using the Git node, under the default `git` security settings, by staging a crafted local repository, an attacker could cause `git` to run hooks, executing arbitrary commands as the n8n process user. Both self-hosted and cloud instances are affected where authenticated users can create and execute workflows using the Git node. ## Patches The issue has been fixed in n8n versions 1.123.67, 2.31.5, and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable the Git node by adding `n8n-nodes-base.git` to the `NODES_EXCLUDE` environment variable. - Restrict network egress from the n8n instance to limit the impact of arbitrary code execution. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Fix Fixed n8n (npm): 1.123.67, 2.32.1, 2.31.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—n8n (npm)before 1.123.671.123.67Patch availableGHSA-rcv6-pvrj-4xcg
—n8n (npm)2.32.0 to before 2.32.12.32.1Patch availableGHSA-rcv6-pvrj-4xcg
—n8n (npm)2.0.0-rc.0 to before 2.31.52.31.5Patch availableGHSA-rcv6-pvrj-4xcg
  • n8n (npm) Vendor— Affected before 1.123.67 Fixed in 1.123.67 Patch available GHSA-rcv6-pvrj-4xcg
  • n8n (npm) Vendor— Affected 2.32.0 to before 2.32.1 Fixed in 2.32.1 Patch available GHSA-rcv6-pvrj-4xcg
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.31.5 Fixed in 2.31.5 Patch available GHSA-rcv6-pvrj-4xcg

Remediation

  • Fix · GHSA-rcv6-pvrj-4xcg n8n (npm) Fixed in 1.123.67 Advisory →
  • Fix · GHSA-rcv6-pvrj-4xcg n8n (npm) Fixed in 2.32.1 Advisory →
  • Fix · GHSA-rcv6-pvrj-4xcg n8n (npm) Fixed in 2.31.5 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-rcv6-pvrj-4xcg

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences