n8n: Credential Authorization Bypass via Expression in HTTP Request Node `genericAuthType`
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-863.
Summary
## Impact An authenticated member with edit access to a shared workflow could reference another user's credential in an HTTP Request node while specifying the credential type through an expression. Because the pre-execution permission check compared the unresolved expression instead of the real credential type, the ownership check was skipped and the credential was loaded at execution time, letting the member use or exfiltrate a credential they were never granted. Exploitation required knowing the target credential's identifier. ## Patches The issue has been fixed in n8n versions 1.123.67, 2.31.5, and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Exclude the HTTP Request node by adding `n8n-nodes-base.httpRequest` to the `NODES_EXCLUDE` environment variable, if the node is not required. - Audit credential sharing and workflow access to limit exposure of credential IDs to untrusted users. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | n8n (npm) | before 1.123.67 | 1.123.67 | Patch available | GHSA-6qc9-mqvw-jg7x |
| — | n8n (npm) | 2.32.0 to before 2.32.1 | 2.32.1 | Patch available | GHSA-6qc9-mqvw-jg7x |
| — | n8n (npm) | 2.0.0-rc.0 to before 2.31.5 | 2.31.5 | Patch available | GHSA-6qc9-mqvw-jg7x |
- n8n (npm) Vendor— Affected before 1.123.67 Fixed in 1.123.67 Patch available GHSA-6qc9-mqvw-jg7x
- n8n (npm) Vendor— Affected 2.32.0 to before 2.32.1 Fixed in 2.32.1 Patch available GHSA-6qc9-mqvw-jg7x
- n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.31.5 Fixed in 2.31.5 Patch available GHSA-6qc9-mqvw-jg7x
Remediation
- Fix · GHSA-6qc9-mqvw-jg7x n8n (npm) Fixed in 1.123.67 Advisory →
- Fix · GHSA-6qc9-mqvw-jg7x n8n (npm) Fixed in 2.32.1 Advisory →
- Fix · GHSA-6qc9-mqvw-jg7x n8n (npm) Fixed in 2.31.5 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-6qc9-mqvw-jg7x
References
Other 6
- https://github.com/n8n-io/n8n/security/advisories/GHSA-6qc9-mqvw-jg7x
- https://github.com/n8n-io/n8n/commit/f69dfc6dd2178a14ea1624d2e1d403c2e755042f
- https://github.com/n8n-io/n8n
- https://github.com/n8n-io/n8n/releases/tag/[email protected]
- https://github.com/n8n-io/n8n/releases/tag/[email protected]
- https://github.com/n8n-io/n8n/releases/tag/[email protected]
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences