Read the docs
TI-2026-67098 Aliases GHSA-xwx6-jjhv-84p8

n8n: Prototype Pollution via Dot-Notation Field Names Leads To Instance-Wide Denial of Service

Priority LOW 38CWE-1321Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

## Impact The Edit Fields (Set) node assigned output fields through a dot-notation path setter without restricting the field name, so an authenticated user could name a field after an inherited built-in method path and corrupt a shared global in the main Node.js process. Because that global was used on the request-authentication path, the instance then failed every authenticated request, causing a instance-wide denial of service for all users until the process was restarted. ## Patches The issue has been fixed in n8n versions 1.123.67, 2.31.5, and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable or restrict workflow creation and execution permissions for untrusted users. - Monitor for unexpected process-wide HTTP 500 errors and restart the process promptly if they occur. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Fix Fixed n8n (npm): 1.123.67, 2.32.1, 2.31.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—n8n (npm)before 1.123.671.123.67Patch availableGHSA-xwx6-jjhv-84p8
—n8n (npm)2.32.0 to before 2.32.12.32.1Patch availableGHSA-xwx6-jjhv-84p8
—n8n (npm)2.0.0-rc.0 to before 2.31.52.31.5Patch availableGHSA-xwx6-jjhv-84p8
  • n8n (npm) Vendor— Affected before 1.123.67 Fixed in 1.123.67 Patch available GHSA-xwx6-jjhv-84p8
  • n8n (npm) Vendor— Affected 2.32.0 to before 2.32.1 Fixed in 2.32.1 Patch available GHSA-xwx6-jjhv-84p8
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.31.5 Fixed in 2.31.5 Patch available GHSA-xwx6-jjhv-84p8

Remediation

  • Fix · GHSA-xwx6-jjhv-84p8 n8n (npm) Fixed in 1.123.67 Advisory →
  • Fix · GHSA-xwx6-jjhv-84p8 n8n (npm) Fixed in 2.32.1 Advisory →
  • Fix · GHSA-xwx6-jjhv-84p8 n8n (npm) Fixed in 2.31.5 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-xwx6-jjhv-84p8

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences