Read the docs
TI-2026-67104 Aliases GHSA-jqwr-vx3p-r266

n8n: PostgresTrigger Node SQL Injection Allows Authenticated Users to Execute Arbitrary…

Priority LOW 38CWE-89Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
SQL injection
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-89.

Summary

## Impact The Postgres Trigger node interpolated user-supplied identifier parameters (channel, function, and trigger names) into SQL statements without proper escaping, so an authenticated user could inject arbitrary SQL executed against the connected PostgreSQL database with the configured credential's privileges. Successful exploitation allows full read and write access to the connected PostgreSQL database. ## Patches The issue has been fixed in n8n versions 1.123.67, 2.31.5 and 2.32.1. Users should upgrade to these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable the PostgresTrigger node by adding `n8n-nodes-base.postgresTrigger` to the `NODES_EXCLUDE` environment variable. - Ensure PostgreSQL credentials used with n8n are configured with the minimum required privileges and do not use SUPERUSER roles. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Fix Fixed n8n (npm): 1.123.67, 2.32.1, 2.31.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—n8n (npm)before 1.123.671.123.67Patch availableGHSA-jqwr-vx3p-r266
—n8n (npm)2.32.0 to before 2.32.12.32.1Patch availableGHSA-jqwr-vx3p-r266
—n8n (npm)2.0.0-rc.0 to before 2.31.52.31.5Patch availableGHSA-jqwr-vx3p-r266
  • n8n (npm) Vendor— Affected before 1.123.67 Fixed in 1.123.67 Patch available GHSA-jqwr-vx3p-r266
  • n8n (npm) Vendor— Affected 2.32.0 to before 2.32.1 Fixed in 2.32.1 Patch available GHSA-jqwr-vx3p-r266
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.31.5 Fixed in 2.31.5 Patch available GHSA-jqwr-vx3p-r266

Remediation

  • Fix · GHSA-jqwr-vx3p-r266 n8n (npm) Fixed in 1.123.67 Advisory →
  • Fix · GHSA-jqwr-vx3p-r266 n8n (npm) Fixed in 2.32.1 Advisory →
  • Fix · GHSA-jqwr-vx3p-r266 n8n (npm) Fixed in 2.31.5 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-jqwr-vx3p-r266

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences