Read the docs
TI-2026-67105 Aliases GHSA-652q-gvq3-74qv

n8n: Snowflake Node executeQuery Operation Allows SQL Injection via Unparameterized Expression Interpolation

Priority LOW 38CWE-89Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
SQL injection
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-89.

Summary

## Impact The n8n Snowflake node's Execute Query operation interpolated expression values directly into the SQL string, making queries built with untrusted data susceptible to SQL injection. Exploitation requires that a workflow author has already embedded untrusted expression data directly in a raw SQL query. ## Patches The issue has been fixed in n8n versions 1.123.67, 2.31.5, and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability. The fix introduces an optional "Query Parameters" field that allows values to be bound via positional placeholders rather than interpolated into the query string. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict workflow creation and editing permissions to fully trusted users only. - Audit existing workflows that use the Snowflake `executeQuery` operation and ensure no expression resolving to externally-controlled data is embedded directly in a raw SQL query string. - Restrict network access to any webhook or trigger endpoints that feed data into Snowflake `executeQuery` nodes. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Fix Fixed n8n (npm): 1.123.67, 2.32.1, 2.31.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—n8n (npm)before 1.123.671.123.67Patch availableGHSA-652q-gvq3-74qv
—n8n (npm)2.32.0 to before 2.32.12.32.1Patch availableGHSA-652q-gvq3-74qv
—n8n (npm)2.0.0-rc.0 to before 2.31.52.31.5Patch availableGHSA-652q-gvq3-74qv
  • n8n (npm) Vendor— Affected before 1.123.67 Fixed in 1.123.67 Patch available GHSA-652q-gvq3-74qv
  • n8n (npm) Vendor— Affected 2.32.0 to before 2.32.1 Fixed in 2.32.1 Patch available GHSA-652q-gvq3-74qv
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.31.5 Fixed in 2.31.5 Patch available GHSA-652q-gvq3-74qv

Remediation

  • Fix · GHSA-652q-gvq3-74qv n8n (npm) Fixed in 1.123.67 Advisory →
  • Fix · GHSA-652q-gvq3-74qv n8n (npm) Fixed in 2.32.1 Advisory →
  • Fix · GHSA-652q-gvq3-74qv n8n (npm) Fixed in 2.31.5 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-652q-gvq3-74qv

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences