ngx-extended-pdf-viewer bundles a version of pdf.js vulnerable to CVE-2026-16633
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
ngx-extended-pdf-viewer embeds a fork of Mozilla's pdf.js rather than depending on pdfjs-dist, so this vulnerability is not visible to dependency scanners through package.json. ### Impact Opening a malicious PDF can execute attacker-controlled JavaScript in the context of the hosting page. Upstream advisory: GHSA-hq66-cqwq-w95j / CVE-2026-16633. ### Exposure. The sandbox half of the issue requires enableScripting, which pdf.js enables by default but this library does not — so the default configuration was less exposed than upstream's. The other half concerns XFA rich text and is reachable whenever enableXfa is true, which is the default here. Do not assume the default configuration was safe. ### Patches 29.0.0-rc.3 cherry-picks Mozilla's fix (pdf.js 6.2.108) into both the stable and bleeding-edge engines. Only the latest release receives security updates. ### Workarounds Set pdfDefaultOptions.enableXfa = false if you do not need XFA forms, and/or apply a CSP disallowing inline script-src. ### Verifying. From 29.0.0 the package ships sbom.json and vex.json. The SBOM records the applied fix as a CycloneDX pedigree.patches entry; the VEX carries a resolved_with_pedigree statement so scanners stop flagging the engine's nominal version.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ngx-extended-pdf-viewer (npm) | 27.0.0-rc.0 to before 29.0.0-rc.3 | 29.0.0-rc.3 | Patch available | GHSA-w9hm-4m3m-fxmm |
- ngx-extended-pdf-viewer (npm) Vendor— Affected 27.0.0-rc.0 to before 29.0.0-rc.3 Fixed in 29.0.0-rc.3 Patch available GHSA-w9hm-4m3m-fxmm
Remediation
- Fix · GHSA-w9hm-4m3m-fxmm ngx-extended-pdf-viewer (npm) Fixed in 29.0.0-rc.3 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-w9hm-4m3m-fxmm
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences