Wagtail: Improper restriction handling on descendant collections in Documents and Images API
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact The Documents and Images [API V2](https://docs.wagtail.org/en/stable/advanced_topics/api/index.html) incorrectly listed items in descendants of private collections, which should inherit the view restrictions defined on their ancestors. A user with access to the API could see the filename and name of documents and images in these descendant collections. ### Patches Patched versions have been released as Wagtail 7.0.9, 7.3.4, 7.4.3 and 8.0rc2. ### Workarounds Site owners using Wagtail's API can avoid the vulnerability by adding [authentication](https://docs.wagtail.org/en/stable/advanced_topics/api/v2/configuration.html#authentication) to the Documents and Images APIs. ### Acknowledgements Many thanks to Ta Duc Thien for reporting this issue. ### For more information If you have any questions or comments about this advisory: * Visit Wagtail's [support channels](https://docs.wagtail.org/en/stable/support.html) * Email us at [[email protected]](mailto:[email protected]) (view our [security policy](https://github.com/wagtail/wagtail/security/policy) for more information).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | wagtail (PyPI) | before 7.0.9 | 7.0.9 | Patch available | GHSA-c2xx-cjmh-9q8f |
| — | wagtail (PyPI) | 7.1 to before 7.3.4 | 7.3.4 | Patch available | GHSA-c2xx-cjmh-9q8f |
| — | wagtail (PyPI) | 7.4 to before 7.4.3 | 7.4.3 | Patch available | GHSA-c2xx-cjmh-9q8f |
| — | wagtail (PyPI) | 8.0rc1 to before 8.0rc2 | 8.0rc2 | Patch available | GHSA-c2xx-cjmh-9q8f |
- wagtail (PyPI) Vendor— Affected before 7.0.9 Fixed in 7.0.9 Patch available GHSA-c2xx-cjmh-9q8f
- wagtail (PyPI) Vendor— Affected 7.1 to before 7.3.4 Fixed in 7.3.4 Patch available GHSA-c2xx-cjmh-9q8f
- wagtail (PyPI) Vendor— Affected 7.4 to before 7.4.3 Fixed in 7.4.3 Patch available GHSA-c2xx-cjmh-9q8f
- wagtail (PyPI) Vendor— Affected 8.0rc1 to before 8.0rc2 Fixed in 8.0rc2 Patch available GHSA-c2xx-cjmh-9q8f
Remediation
- Fix · GHSA-c2xx-cjmh-9q8f wagtail (PyPI) Fixed in 7.0.9 Advisory →
- Fix · GHSA-c2xx-cjmh-9q8f wagtail (PyPI) Fixed in 7.3.4 Advisory →
- Fix · GHSA-c2xx-cjmh-9q8f wagtail (PyPI) Fixed in 7.4.3 Advisory →
- Fix · GHSA-c2xx-cjmh-9q8f wagtail (PyPI) Fixed in 8.0rc2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-c2xx-cjmh-9q8f
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences