Read the docs
TI-2026-67293 Aliases GHSA-rgj7-g3m4-5g8c

sharp: Vulnerabilities in libheif: GHSA-g89c-p67h-r497 and GHSA-2jg2-4ch7-h545

Priority LOW 38CWE-122Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact A number of vulnerabilities, two rated as "Critical" severity using CVSSv3, have been discovered and fixed in the upstream libheif dependency. These can lead to possible remote code execution (RCE) on glibc-based Linux when run under certain conditions. The attack vector for these claims to be "network" however sharp does not provide any networking features so this vulnerability is down-rated to a "High" severity using CVSSv4 but please note its Subsequent System Impact. Those processing untrusted input with versions of sharp prior to 0.35.4 are affected. ### Patches #### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest version, currently 0.35.4, which provides libheif 1.23.2. #### Using a globally-installed libheif? Please ensure you are using the latest libheif 1.23.2. ### Workarounds Add the following to your code to prevent sharp from decoding AVIF images. ```js sharp.block({ operation: ["VipsForeignLoadHeif"] }); ``` Ensure you are using a `node` executable binary compiled as a Position Independent Executable (PIE). Most Linux package managers already do this for protection against RCE however be warned that the "official" Node.js binaries do not. ### References - [CVE-2026-84383](https://github.com/strukturag/libheif/security/advisories/GHSA-g89c-p67h-r497) - https://github.com/strukturag/libheif/security/advisories/GHSA-2jg2-4ch7-h545

Why it matters now

Fix Fixed sharp (npm): 0.35.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—sharp (npm)before 0.35.40.35.4Patch availableGHSA-rgj7-g3m4-5g8c
  • sharp (npm) Vendor— Affected before 0.35.4 Fixed in 0.35.4 Patch available GHSA-rgj7-g3m4-5g8c

Remediation

  • Fix · GHSA-rgj7-g3m4-5g8c sharp (npm) Fixed in 0.35.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-rgj7-g3m4-5g8c

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences