sqlite3-ruby: Use-After-Free in SQLite Aggregate Arguments in Heap-Allocated Argument Array
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
## Summary Using `Database#create_aggregate`, `#create_aggregate_handler`, or `Database#define_aggregator` to define an aggregate function that takes two or more arguments, and then evaluating it over TEXT or BLOB column values, can free the Ruby objects holding those arguments while a later argument is still being converted, during ordinary garbage collection. The aggregate's `step` method then receives an incorrect object, or the process crashes with a segmentation fault. ## Mitigation Upgrade to sqlite3 gem v2.9.6 or later. There is no reliable workaround. If you cannot upgrade, avoid defining aggregate functions that take two or more arguments. Restricting column value sizes is not a mitigation: smaller values make the defect fire less often but do not prevent it. ## Severity The sqlite3-ruby maintainers assess this as Medium severity (CVSS 4.0 score 6.3). It is reached through ordinary garbage collection without any unusual code structuring: an application is exposed whenever it evaluates a multi-argument aggregate over TEXT or BLOB values whose size an attacker can influence. The demonstrated impact is an incorrect value passed to the aggregate's `step` method, or a process crash; no controlled memory write or general denial-of-service exploit has been demonstrated. ## Credits Reported by Jeremy Daer ([@jeremy](https://github.com/jeremy)).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | sqlite3 (RubyGems) | 1.4.0 to before 2.9.6 | 2.9.6 | Patch available | GHSA-mwm8-39rw-8826 |
- sqlite3 (RubyGems) Vendor— Affected 1.4.0 to before 2.9.6 Fixed in 2.9.6 Patch available GHSA-mwm8-39rw-8826
Remediation
- Fix · GHSA-mwm8-39rw-8826 sqlite3 (RubyGems) Fixed in 2.9.6 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-mwm8-39rw-8826
References
Other 5
- https://github.com/sparklemotion/sqlite3-ruby/security/advisories/GHSA-mwm8-39rw-8826
- https://github.com/sparklemotion/sqlite3-ruby/pull/733
- https://github.com/sparklemotion/sqlite3-ruby/commit/cc5ac0cdf05af8148f4363410da0ba32508d9c97
- https://github.com/sparklemotion/sqlite3-ruby
- https://github.com/sparklemotion/sqlite3-ruby/releases/tag/v2.9.6
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences