Read the docs

Stored cross-site scripting in Ghost embed card previews

Priority LOW 34CWE-653Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Ghost from 6.34.0 before 6.67.0 is affected. Embed cards in the Ghost editor bypass protections against stored cross-site scripting (CWE-79). A staff user with low privileges, including a Contributor, can store scripts in post content that run when another staff user opens the post in the editor, potentially compromising that user's admin session.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new  security.embedPreviewUrl  configuration option at its default value. This issue is fixed in version 6.67.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00277 20th percentileScored 2026-11-07
Fix Fixed Ghost (TryGhost): 6.67.0ghost (npm): 6.67.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
TryGhostGhost6.34.0 to before 6.67.06.67.0Patch availableCNA
—ghost (npm)6.34.0 to before 6.67.06.67.0Patch availableGHSA-69qc-f5m6-889c
  • Ghost VendorTryGhost Affected 6.34.0 to before 6.67.0 Fixed in 6.67.0 Patch available CNA
  • ghost (npm) Vendor— Affected 6.34.0 to before 6.67.0 Fixed in 6.67.0 Patch available GHSA-69qc-f5m6-889c

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:ghost:ghost:*:*:*:*:*:*:*:*——TryGhost
  • cpe:2.3:a:ghost:ghost:*:*:*:*:*:*:*:* Versions — — ·TryGhost

Remediation

Upgrade the npm package ghost to version 6.67.0, which fixes this issue. Self-hosted sites should leave the security.embedPreviewUrl configuration option at its default value.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA Ghost (TryGhost) Fixed in 6.67.0
  • Fix · GHSA-69qc-f5m6-889c ghost (npm) Fixed in 6.67.0 Advisory →

Timeline

  1. 2026-10-05 Threatist record created from CVE-2026-105643
  2. 2026-10-06 CISA SSVC decision points changed
  3. 2026-10-06 Priority changed: MEDIUM → LOW
  4. 2026-10-07 Alias added: GHSA-69qc-f5m6-889c
  5. 2026-10-07 Fix available: npm/[email protected] · GHSA-69qc-f5m6-889c
  6. 2026-10-07 CVSS score added · GHSA-69qc-f5m6-889c
  7. 2026-10-07 Weakness changed · GHSA-69qc-f5m6-889c
  8. 2026-10-07 4 new references · GHSA-69qc-f5m6-889c

References

  • TI-2026-21459 Ghost has a SQL Injection in its Content API CVSS 3.1CRITICAL 9.4
  • TI-2022-10277 An arbitrary file upload vulnerability in the file upload module of Ghost v4.39.0 allows… CVSS 3.1CRITICAL 9.8
  • TI-2024-22785 Ghost through 5.85.1 allows remote attackers to bypass an authentication rate-limit… CVSS 3.1CRITICAL 9.1
  • TI-2023-14843 Ghost vulnerable to disclosure of private API fields CVSS 3.1HIGH 7.5
  • TI-2025-09049 Ghost 6.0.6 - SSRF via oEmbed Bookmark CVSS 4.0MEDIUM 6.1
  • TI-2023-20918 Arbitrary file read via symlinks in Ghost CVSS 3.1MEDIUM 6.5
See all 109 →

Sources