Read the docs

Stored cross-site scripting in Ghost via oEmbed photo responses

Priority LOW 37CWE-184Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Ghost versions from 2.5.0 before 6.64.0 are affected by stored cross-site scripting. Embedding a URL from an attacker-controlled website stores untrusted scripts in post content (CWE-79). A remote attacker can get those scripts to run in the Ghost editor, on the published site and in newsletter emails when a user views the content, possibly compromising a staff user's admin session.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

Ghost is a Node.js content management system. From 2.1.0 until 6.64.0, embedding a URL from an attacker-controlled website could result in untrusted scripts being stored in post content. These scripts could run in the Ghost editor, on the published site, and in newsletter emails, possibly resulting in compromise of a staff user's admin session. This issue is fixed in version 6.64.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00328 26th percentileScored 2026-11-07
Fix Fixed Ghost (TryGhost): 6.64.0ghost (npm): 6.64.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
TryGhostGhost2.5.0 to before 6.64.06.64.0Patch availableCNA
—ghost (npm)2.5.0 to before 6.64.06.64.0Patch availableGHSA-v3xr-g6p2-fvgv
  • Ghost VendorTryGhost Affected 2.5.0 to before 6.64.0 Fixed in 6.64.0 Patch available CNA
  • ghost (npm) Vendor— Affected 2.5.0 to before 6.64.0 Fixed in 6.64.0 Patch available GHSA-v3xr-g6p2-fvgv

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:ghost:ghost:*:*:*:*:*:*:*:*——TryGhost
  • cpe:2.3:a:ghost:ghost:*:*:*:*:*:*:*:* Versions — — ·TryGhost

Remediation

Update Ghost to version 6.64.0, which fixes this issue. Ghost versions before 6.64.0 remain affected.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA Ghost (TryGhost) Fixed in 6.64.0
  • Fix · GHSA-v3xr-g6p2-fvgv ghost (npm) Fixed in 6.64.0 Advisory →

Timeline

  1. 2026-10-05 Threatist record created from CVE-2026-105650
  2. 2026-10-06 CISA SSVC decision points changed
  3. 2026-10-06 Priority changed: MEDIUM → LOW
  4. 2026-10-07 Alias added: GHSA-v3xr-g6p2-fvgv
  5. 2026-10-07 Fix available: npm/[email protected] · GHSA-v3xr-g6p2-fvgv
  6. 2026-10-07 CVSS score added · GHSA-v3xr-g6p2-fvgv
  7. 2026-10-07 Weakness changed · GHSA-v3xr-g6p2-fvgv
  8. 2026-10-07 6 new references · GHSA-v3xr-g6p2-fvgv

References

  • TI-2026-21459 Ghost has a SQL Injection in its Content API CVSS 3.1CRITICAL 9.4
  • TI-2022-10277 An arbitrary file upload vulnerability in the file upload module of Ghost v4.39.0 allows… CVSS 3.1CRITICAL 9.8
  • TI-2024-22785 Ghost through 5.85.1 allows remote attackers to bypass an authentication rate-limit… CVSS 3.1CRITICAL 9.1
  • TI-2023-14843 Ghost vulnerable to disclosure of private API fields CVSS 3.1HIGH 7.5
  • TI-2025-09049 Ghost 6.0.6 - SSRF via oEmbed Bookmark CVSS 4.0MEDIUM 6.1
  • TI-2023-20918 Arbitrary file read via symlinks in Ghost CVSS 3.1MEDIUM 6.5
See all 109 →

Sources