Memory exhaustion in Django get_supported_language_variant()
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 10 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-789.
Summary
Django 6.1 before 6.1.2, 6.0 before 6.0.9, and 5.2 before 5.2.18 are affected. The django.utils.translation.get_supported_language_variant() function keeps many distinct, very long language codes as keys in an in-memory cache, which can exhaust process memory (CWE-789). An unauthenticated remote attacker can cause a denial of service by sending many such language codes. Earlier unsupported series such as 5.1.x, 5.0.x, and 4.2.x were not evaluated and may also be affected.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
An issue was discovered in Django 6.1 before 6.1.2, 6.0 before 6.0.9, and 5.2 before 5.2.18. `django.utils.translation.get_supported_language_variant()` is subject to a potential denial-of-service attack when processing many distinct, very long language codes, which are retained as keys in an in-memory cache and consume process memory. Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected. Django would like to thank Gleb Lizunov for reporting this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| djangoproject | Django | 6.1 to before 6.1.2; 6.0 to before 6.0.9; 5.2 to before 5.2.18 | 6.1.2, 6.0.9, 5.2.18 | Patch available | CNA |
- Django Vendordjangoproject Affected 6.1 to before 6.1.2; 6.0 to before 6.0.9; 5.2 to before 5.2.18 Fixed in 6.1.2, 6.0.9, 5.2.18 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | — | — | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions — — ·djangoproject
Remediation
Upgrade Django to 6.1.2, 6.0.9, or 5.2.18. Red Hat lists Red Hat Ansible Automation Platform 2, Red Hat Discovery 2, Red Hat OpenStack Platform 13 (Queens), Red Hat OpenStack Platform 16.2, Red Hat OpenStack Platform 17.1, Red Hat OpenStack Platform 18.0, Red Hat Satellite 6, Red Hat Update Infrastructure 4 for Cloud Providers, Red Hat Update Infrastructure 5, and Self-service automation portal 2 as affected without a fix, with no fix planned for Red Hat OpenStack Platform 13 (Queens), 16.2, 17.1 and Red Hat Update Infrastructure 4 for Cloud Providers.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Django (djangoproject) Fixed in 6.1.2, 6.0.9, 5.2.18
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
djangoproject Django — Django security releases issued: 6.1.2, 6.0.9, and 5.2.18
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2026-68438 Quadratic parsing in Django HTTP headers allows denial of servicePriority LOW 37
- TI-2026-68440 Server-side request forgery in Django spatial lookup bytes valuesPriority LOW 36
- TI-2026-68441 Authorization bypass in Django model formsets lets users delete rowsPriority LOW 23
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Discovery 2 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 16.2 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 17.1 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 18.0 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
| Red Hat Update Infrastructure 4 for Cloud Providers | Affected | No fix planned: Out of support scope |
| Red Hat Update Infrastructure 5 | Affected | No fix yet: Fix deferred |
| Self-service automation portal 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-06 Threatist record created from CVE-2026-77050
- 2026-10-06 Alias added: GHSA-mxcg-2f2x-4q92
- 2026-10-07 Affected versions changed · Red Hat
- 2026-10-07 CVSS score added · Red Hat
- 2026-10-07 Affected versions changed · Red Hat
- 2026-10-07 CVSS score changed · Red Hat
References
Patch 4
- https://github.com/django/django/commit/c88b304cc2d90fc37d3bd1f5f3829706fa6c13bc
- https://github.com/django/django/commit/7e878b0f8bd42260903e6a0d38996a93b0474a0b
- https://github.com/django/django/commit/3d32ee80ae52745d686bf94d3555000ddf073267
- https://github.com/django/django/commit/02a69e3791e3df23d45ea4ea7e7fc489f0eef2be
More djangoproject vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-77050 · CVE Program
- CVE-2026-77050 · NVD
- FIRST EPSS
- GHSA-mxcg-2f2x-4q92 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-77050 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences