Editor role can execute arbitrary PHP via WP Coder WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-94.
Summary
The WP Coder WordPress plugin from 4.0 before 4.5.2 does not restrict its PHP code-execution feature to administrators. An authenticated user with the Editor role can save and execute arbitrary PHP code on the server, which is a code injection flaw (CWE-94) that fully compromises the site. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The WP Coder WordPress plugin before 4.5.2 does not restrict access to its PHP code-execution feature to administrators, gating it on a content capability that the Editor role holds by default, which allows Editor-level users to save and execute arbitrary PHP code on the server and fully compromise the site.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Coder | 4.0 to before 4.5.2 | 4.5.2 | Patch available | CNA |
- WP Coder VendorUnknown Affected 4.0 to before 4.5.2 Fixed in 4.5.2 Patch available CNA
Remediation
Update WP Coder to version 4.5.2.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA WP Coder (Unknown) Fixed in 4.5.2
Timeline
- 2026-10-07 Threatist record created from CVE-2026-104677
- 2026-10-07 Alias added: GHSA-pfgx-g476-6w3m
- 2026-10-07 CVSS score added · CISA ADP
- 2026-10-07 Weakness changed · CISA ADP
- 2026-10-07 CISA SSVC decision points changed
References
Sources
- CVE-2026-104677 · CVE Program
- CVE-2026-104677 · NVD
- FIRST EPSS
- GHSA-pfgx-g476-6w3m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences