Inconsistent credential enforcement in Backstage proxy routes
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.
Summary
The @backstage/plugin-proxy-backend package from 0.5.0 before 0.6.18 enforces credentials inconsistently for overlapping proxy routes (CWE-863). When a parent path allows unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated remote attacker can therefore reach the nested upstream through Backstage, including when static upstream credentials are configured for that proxy.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | backstage | 1.28.0 to before 1.55.0 | 1.55.0 | Patch available | CNA |
| backstage | plugin-proxy-backend | 0.5.0 to before 0.6.18 | 0.6.18 | Patch available | CNA |
| — | @backstage/plugin-proxy-backend (npm) | 0.5.0 to before 0.6.18 | 0.6.18 | Patch available | GHSA-472h-9c5j-prrr |
- backstage Vendorbackstage Affected 1.28.0 to before 1.55.0 Fixed in 1.55.0 Patch available CNA
- plugin-proxy-backend Vendorbackstage Affected 0.5.0 to before 0.6.18 Fixed in 0.6.18 Patch available CNA
- @backstage/plugin-proxy-backend (npm) Vendor— Affected 0.5.0 to before 0.6.18 Fixed in 0.6.18 Patch available GHSA-472h-9c5j-prrr
Remediation
Upgrade @backstage/plugin-proxy-backend to version 0.6.18, which fixes this issue. The sources list no fixed version for backstage. Red Hat rates this Moderate and lists Red Hat Developer Hub 1 and Self-service automation portal 2 as affected, with no plan available.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA backstage (backstage) Fixed in 1.55.0
- Fix · CNA plugin-proxy-backend (@backstage) Fixed in 0.6.18
- Fix · GHSA-472h-9c5j-prrr @backstage/plugin-proxy-backend (npm) Fixed in 0.6.18 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Developer Hub 1 | Affected | No fix yet: Fix deferred |
| Self-service automation portal 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-07 Threatist record created from CVE-2026-106456
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-07 Alias added: GHSA-472h-9c5j-prrr
- 2026-10-07 Fix available: npm/@backstage/[email protected] · GHSA-472h-9c5j-prrr
- 2026-10-07 CVSS score added · GHSA-472h-9c5j-prrr
- 2026-10-07 Weakness changed · GHSA-472h-9c5j-prrr
- 2026-10-07 5 new references · GHSA-472h-9c5j-prrr
- 2026-10-08 Affected versions changed · Red Hat
- 2026-10-08 CVSS score added · Red Hat
- 2026-10-27 Affected versions changed · Red Hat
- 2026-10-27 CVSS score added · NVD
References
Patch 2
Advisory 2
More Backstage vulnerabilities
- TI-2023-17988 Insecure sandbox in Backstage Scaffolder plugin CVSS 3.1CRITICAL 9.9
- TI-2026-69075 Sensitive information exposure in Backstage Scaffolder CVSS 3.1CRITICAL 9.6
- TI-2026-69061 Path traversal in Backstage Bitbucket pull-request scaffolder actions CVSS 3.1CRITICAL 9.9
- TI-2026-60083 Backstage: Improper input validation in TechDocs MkDocs configuration CVSS 3.1HIGH 8.8
- TI-2026-69165 Backstage TechDocs config flaw allows code execution CVSS 3.1HIGH 8.8
- TI-2026-69083 Code injection via MkDocs theme configuration in Backstage TechDocs CVSS 3.1HIGH 8.8
Sources
- CVE-2026-106456 · CVE Program
- CVE-2026-106456 · NVD
- FIRST EPSS
- GHSA-472h-9c5j-prrr · GitHub Advisory Database · CC BY 4.0
- CVE-2026-106456 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences