Improper input validation in Backstage Sentry scaffolder actions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The @backstage/plugin-scaffolder-backend-module-sentry package is affected from 0.3.0 before 0.3.8. Improper input validation in its Sentry scaffolder actions lets the backend contact unintended destinations (CWE-918). An authenticated internal user who can run these actions may also disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Backstage is an open framework for building developer portals. From 0.3.0 until 0.3.8, the @backstage/plugin-scaffolder-backend-module-sentry package is affected by improper input validation in sentry scaffolder actions. An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. This issue is fixed in version 0.3.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | backstage | 1.47.0 to before 1.54.8 | 1.54.8 | Patch available | CNA |
| backstage | plugin-scaffolder-backend-module-sentry | 0.3.0 to before 0.3.8 | 0.3.8 | Patch available | CNA |
| — | @backstage/plugin-scaffolder-backend-module-sentry (npm) | 0.3.0 to before 0.3.8 | 0.3.8 | Patch available | GHSA-g734-fhp4-7mfp |
- backstage Vendorbackstage Affected 1.47.0 to before 1.54.8 Fixed in 1.54.8 Patch available CNA
- plugin-scaffolder-backend-module-sentry Vendorbackstage Affected 0.3.0 to before 0.3.8 Fixed in 0.3.8 Patch available CNA
- @backstage/plugin-scaffolder-backend-module-sentry (npm) Vendor— Affected 0.3.0 to before 0.3.8 Fixed in 0.3.8 Patch available GHSA-g734-fhp4-7mfp
Remediation
Upgrade @backstage/plugin-scaffolder-backend-module-sentry to version 0.3.8, which fixes this issue. The sources list no fixed version for backstage.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA backstage (backstage) Fixed in 1.54.8
- Fix · CNA plugin-scaffolder-backend-module-sentry (@backstage) Fixed in 0.3.8
- Fix · GHSA-g734-fhp4-7mfp @backstage/plugin-scaffolder-backend-module-sentry (npm) Fixed in 0.3.8 Advisory →
Timeline
- 2026-10-07 Threatist record created from CVE-2026-106459
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-07 Priority changed: MEDIUM → LOW
- 2026-10-07 Alias added: GHSA-g734-fhp4-7mfp
- 2026-10-07 Fix available: npm/@backstage/[email protected] · GHSA-g734-fhp4-7mfp
- 2026-10-07 CVSS score added · GHSA-g734-fhp4-7mfp
- 2026-10-07 Weakness changed · GHSA-g734-fhp4-7mfp
- 2026-10-07 6 new references · GHSA-g734-fhp4-7mfp
References
Patch 3
Advisory 2
More Backstage vulnerabilities
- TI-2023-17988 Insecure sandbox in Backstage Scaffolder plugin CVSS 3.1CRITICAL 9.9
- TI-2026-69075 Sensitive information exposure in Backstage Scaffolder CVSS 3.1CRITICAL 9.6
- TI-2026-69061 Path traversal in Backstage Bitbucket pull-request scaffolder actions CVSS 3.1CRITICAL 9.9
- TI-2026-60083 Backstage: Improper input validation in TechDocs MkDocs configuration CVSS 3.1HIGH 8.8
- TI-2026-69165 Backstage TechDocs config flaw allows code execution CVSS 3.1HIGH 8.8
- TI-2026-69083 Code injection via MkDocs theme configuration in Backstage TechDocs CVSS 3.1HIGH 8.8
Sources
- CVE-2026-106459 · CVE Program
- CVE-2026-106459 · NVD
- FIRST EPSS
- GHSA-g734-fhp4-7mfp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences