Path traversal in Backstage proxy-backend
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Backstage, an open framework for developer portals, has improper input validation in the @backstage/plugin-proxy-backend package before 0.6.17. A crafted request URL makes the proxy forward requests to a path outside the configured base path on the target server (CWE-22). An authenticated Backstage user with low privileges can trigger it, but only against target servers already configured as proxy endpoints.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | backstage | before 1.54.6 | 1.54.6 | Patch available | CNA |
| backstage | plugin-proxy-backend | before 0.6.17 | 0.6.17 | Patch available | CNA |
| — | @backstage/plugin-proxy-backend (npm) | before 0.6.17 | 0.6.17 | Patch available | GHSA-9ghw-48h5-v2w5 |
Remediation
Update @backstage/plugin-proxy-backend to version 0.6.17, which fixes the flaw. The sources list no fixed version for backstage. Red Hat rates this Moderate and lists Red Hat Developer Hub 1 and Self-service automation portal 2 as affected without a fix, with no plan available.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA backstage (backstage) Fixed in 1.54.6
- Fix · CNA plugin-proxy-backend (@backstage) Fixed in 0.6.17
- Fix · GHSA-9ghw-48h5-v2w5 @backstage/plugin-proxy-backend (npm) Fixed in 0.6.17 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Developer Hub 1 | Affected | No fix yet: Fix deferred |
| Self-service automation portal 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-07 Threatist record created from CVE-2026-106491
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-07 Priority changed: MEDIUM → LOW
- 2026-10-07 Alias added: GHSA-9ghw-48h5-v2w5
- 2026-10-07 Fix available: npm/@backstage/[email protected] · GHSA-9ghw-48h5-v2w5
- 2026-10-07 CVSS score added · GHSA-9ghw-48h5-v2w5
- 2026-10-07 Weakness changed · GHSA-9ghw-48h5-v2w5
- 2026-10-07 5 new references · GHSA-9ghw-48h5-v2w5
- 2026-10-09 Affected versions changed · Red Hat
- 2026-10-09 CVSS score added · Red Hat
- 2026-10-27 Affected versions changed · Red Hat
References
Patch 2
Advisory 2
More Backstage vulnerabilities
- TI-2023-17988 Insecure sandbox in Backstage Scaffolder plugin CVSS 3.1CRITICAL 9.9
- TI-2026-69075 Sensitive information exposure in Backstage Scaffolder CVSS 3.1CRITICAL 9.6
- TI-2026-69061 Path traversal in Backstage Bitbucket pull-request scaffolder actions CVSS 3.1CRITICAL 9.9
- TI-2026-60083 Backstage: Improper input validation in TechDocs MkDocs configuration CVSS 3.1HIGH 8.8
- TI-2026-69165 Backstage TechDocs config flaw allows code execution CVSS 3.1HIGH 8.8
- TI-2026-69083 Code injection via MkDocs theme configuration in Backstage TechDocs CVSS 3.1HIGH 8.8
Sources
- CVE-2026-106491 · CVE Program
- CVE-2026-106491 · NVD
- FIRST EPSS
- GHSA-9ghw-48h5-v2w5 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-106491 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences