Remote code execution in Backstage TechDocs via crafted mkdocs.yml
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
The @backstage/plugin-techdocs-node package before 1.14.6, and from 1.15.0 before 1.15.4, is affected. Crafted markdown_extensions values in a TechDocs mkdocs.yml file lead to unsafe selection of code (CWE-470). An authenticated user who can register catalog entities can run arbitrary OS commands on the TechDocs build host when the docs are built. Backstage releases before 1.50.5, and from 1.51.0-next.0 before 1.54.6, are also listed as affected.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Backstage is an open framework for building developer portals. Prior to 1.14.6, the @backstage/plugin-techdocs-node package is affected by remote code execution via crafted markdown_extensions in techdocs mkdocs.yml. An authenticated user who can register catalog entities can provide a crafted mkdocs.yml causing arbitrary OS command execution on the TechDocs build host when the docs are built. This issue is fixed in versions 1.14.6 and 1.15.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | backstage | before 1.50.5; 1.51.0-next.0 to before 1.54.6 | 1.50.5, 1.54.6 | Patch available | CNA |
| backstage | plugin-techdocs-node | before 1.14.6; 1.15.0 to before 1.15.4 | 1.14.6, 1.15.4 | Patch available | CNA |
| — | @backstage/plugin-techdocs-node (npm) | before 1.15.4 | 1.15.4 | Patch available | GHSA-4488-j8vj-vqqv |
- backstage Vendorbackstage Affected before 1.50.5; 1.51.0-next.0 to before 1.54.6 Fixed in 1.50.5, 1.54.6 Patch available CNA
- plugin-techdocs-node Vendorbackstage Affected before 1.14.6; 1.15.0 to before 1.15.4 Fixed in 1.14.6, 1.15.4 Patch available CNA
- @backstage/plugin-techdocs-node (npm) Vendor— Affected before 1.15.4 Fixed in 1.15.4 Patch available GHSA-4488-j8vj-vqqv
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:linuxfoundation:backstage_plugin-techdocs-node:*:*:*:*:*:*:*:* | before 1.14.6; 1.15.0 to before 1.15.4 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:backstage:*:*:*:*:*:*:*:* | before 1.50.5; 1.51.1 to before 1.54.6 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:backstage:1.51.0:-:*:*:*:*:*:* | 1.51.0 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:backstage:1.51.0:next0:*:*:*:*:*:* | 1.51.0 next0 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:backstage:1.51.0:next1:*:*:*:*:*:* | 1.51.0 next1 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:backstage:1.51.0:next2:*:*:*:*:*:* | 1.51.0 next2 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:backstage:1.51.0:next3:*:*:*:*:*:* | 1.51.0 next3 | Vulnerable | backstage |
- cpe:2.3:a:linuxfoundation:backstage_plugin-techdocs-node:*:*:*:*:*:*:*:* Versions before 1.14.6; 1.15.0 to before 1.15.4 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:backstage:*:*:*:*:*:*:*:* Versions before 1.50.5; 1.51.1 to before 1.54.6 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:backstage:1.51.0:-:*:*:*:*:*:* Versions 1.51.0 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:backstage:1.51.0:next0:*:*:*:*:*:* Versions 1.51.0 next0 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:backstage:1.51.0:next1:*:*:*:*:*:* Versions 1.51.0 next1 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:backstage:1.51.0:next2:*:*:*:*:*:* Versions 1.51.0 next2 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:backstage:1.51.0:next3:*:*:*:*:*:* Versions 1.51.0 next3 Vulnerable ·backstage
Remediation
Upgrade @backstage/plugin-techdocs-node to 1.14.6 or 1.15.4. The sources list no fixed version for backstage. Red Hat's plan for Red Hat Developer Hub 1 and Self-service automation portal 2 is none available.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA backstage (backstage) Fixed in 1.50.5, 1.54.6
- Fix · CNA plugin-techdocs-node (@backstage) Fixed in 1.14.6, 1.15.4
- Fix · GHSA-4488-j8vj-vqqv @backstage/plugin-techdocs-node (npm) Fixed in 1.15.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Developer Hub 1 | Affected | No fix yet |
| Self-service automation portal 2 | Affected | No fix yet |
Timeline
- 2026-10-07 Threatist record created from CVE-2026-106510
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-07 Priority changed: MEDIUM → LOW
- 2026-10-07 Alias added: GHSA-4488-j8vj-vqqv
- 2026-10-07 Fix available: npm/@backstage/[email protected] · GHSA-4488-j8vj-vqqv
- 2026-10-07 CVSS score added · GHSA-4488-j8vj-vqqv
- 2026-10-07 Weakness changed · GHSA-4488-j8vj-vqqv
- 2026-10-07 7 new references · GHSA-4488-j8vj-vqqv
- 2026-10-08 Affected versions changed · Red Hat
- 2026-10-08 CVSS score added · Red Hat
- 2026-10-27 Affected versions changed · Red Hat
References
Patch 4
Advisory 2
More Backstage vulnerabilities
- TI-2023-17988 Insecure sandbox in Backstage Scaffolder plugin CVSS 3.1CRITICAL 9.9
- TI-2026-69075 Sensitive information exposure in Backstage Scaffolder CVSS 3.1CRITICAL 9.6
- TI-2026-69061 Path traversal in Backstage Bitbucket pull-request scaffolder actions CVSS 3.1CRITICAL 9.9
- TI-2026-60083 Backstage: Improper input validation in TechDocs MkDocs configuration CVSS 3.1HIGH 8.8
- TI-2026-69165 Backstage TechDocs config flaw allows code execution CVSS 3.1HIGH 8.8
- TI-2026-69083 Code injection via MkDocs theme configuration in Backstage TechDocs CVSS 3.1HIGH 8.8
Sources
- CVE-2026-106510 · CVE Program
- CVE-2026-106510 · NVD
- FIRST EPSS
- GHSA-4488-j8vj-vqqv · GitHub Advisory Database · CC BY 4.0
- CVE-2026-106510 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences