Input validation flaw in Backstage Confluence to Markdown scaffolder
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The @backstage/plugin-scaffolder-backend-module-confluence-to-markdown npm package in Backstage is affected before 0.3.25. Insufficient input validation (CWE-22) lets attackers influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper input validation in confluence to markdown scaffolder module. Insufficient input validation in the Confluence to Markdown scaffolder module could allow an attacker to influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content. This issue is fixed in version 0.3.25.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | backstage | before 1.54.6 | 1.54.6 | Patch available | CNA |
| backstage | plugin-scaffolder-backend-module-confluence-to-markdown | before 0.3.25 | 0.3.25 | Patch available | CNA |
| — | @backstage/plugin-scaffolder-backend-module-confluence-to-markdown (npm) | before 0.3.25 | 0.3.25 | Patch available | GHSA-75qf-886x-5xf2 |
- backstage Vendorbackstage Affected before 1.54.6 Fixed in 1.54.6 Patch available CNA
- plugin-scaffolder-backend-module-confluence-to-markdown Vendorbackstage Affected before 0.3.25 Fixed in 0.3.25 Patch available CNA
- @backstage/plugin-scaffolder-backend-module-confluence-to-markdown (npm) Vendor— Affected before 0.3.25 Fixed in 0.3.25 Patch available GHSA-75qf-886x-5xf2
Remediation
Update the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package to version 0.3.25. The sources list no fixed version for backstage.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA backstage (backstage) Fixed in 1.54.6
- Fix · CNA plugin-scaffolder-backend-module-confluence-to-markdown (@backstage) Fixed in 0.3.25
- Fix · GHSA-75qf-886x-5xf2 @backstage/plugin-scaffolder-backend-module-confluence-to-markdown (npm) Fixed in 0.3.25 Advisory →
Timeline
- 2026-10-07 Threatist record created from CVE-2026-106559
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-07 Priority changed: MEDIUM → LOW
- 2026-10-07 Alias added: GHSA-75qf-886x-5xf2
- 2026-10-07 Fix available: npm/@backstage/[email protected] · GHSA-75qf-886x-5xf2
- 2026-10-07 CVSS score added · GHSA-75qf-886x-5xf2
- 2026-10-07 Weakness changed · GHSA-75qf-886x-5xf2
- 2026-10-07 5 new references · GHSA-75qf-886x-5xf2
- 2026-10-16 CVSS score added · NVD
References
Patch 2
Advisory 2
More Backstage vulnerabilities
- TI-2023-17988 Insecure sandbox in Backstage Scaffolder plugin CVSS 3.1CRITICAL 9.9
- TI-2026-69075 Sensitive information exposure in Backstage Scaffolder CVSS 3.1CRITICAL 9.6
- TI-2026-69061 Path traversal in Backstage Bitbucket pull-request scaffolder actions CVSS 3.1CRITICAL 9.9
- TI-2026-60083 Backstage: Improper input validation in TechDocs MkDocs configuration CVSS 3.1HIGH 8.8
- TI-2026-69165 Backstage TechDocs config flaw allows code execution CVSS 3.1HIGH 8.8
- TI-2026-69083 Code injection via MkDocs theme configuration in Backstage TechDocs CVSS 3.1HIGH 8.8
Sources
- CVE-2026-106559 · CVE Program
- CVE-2026-106559 · NVD
- FIRST EPSS
- GHSA-75qf-886x-5xf2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences