Infinite loop in ImageMagick PSD decoder on 32-bit builds
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-835.
Summary
ImageMagick versions before 6.9.13-57 and from 7.0.0 before 7.1.2-32 are affected. An integer conversion error in the PSD decoder, classified as CWE-196, causes an infinite loop on 32-bit builds. A remote attacker can cause a denial of service by supplying a crafted PSD file, without privileges or user interaction.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-32 and 6.9.13-57, a crafted PSD file can trigger an integer-conversion error in the PSD decoder on 32-bit builds, causing an infinite loop and denial of service. This issue is fixed in versions 7.1.2-32 and 6.9.13-57.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ImageMagick | ImageMagick | before 6.9.13-57; 7.0.0 to before 7.1.2-32 | 6.9.13-57, 7.1.2-32 | Patch available | CNA |
- ImageMagick VendorImageMagick Affected before 6.9.13-57; 7.0.0 to before 7.1.2-32 Fixed in 6.9.13-57, 7.1.2-32 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* | before 6.9.13-57; 7.0.0-0 to before 7.1.2-32 | Vulnerable | ImageMagick |
- cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* Versions before 6.9.13-57; 7.0.0-0 to before 7.1.2-32 Vulnerable ·ImageMagick
Remediation
Upgrade to ImageMagick 7.1.2-32 or 6.9.13-57, which fix this issue. Red Hat lists Red Hat Enterprise Linux 6 as affected with no fix planned and Red Hat Enterprise Linux 7 as affected with none available.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA ImageMagick (ImageMagick) Fixed in 6.9.13-57, 7.1.2-32
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-07 Threatist record created from CVE-2026-106567
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-07 Priority changed: MEDIUM → LOW
- 2026-10-08 Affected versions changed · Red Hat
- 2026-10-08 CVSS score added · Red Hat
- 2026-10-23 CVSS score added · NVD
References
Patch 4
- https://github.com/ImageMagick/ImageMagick/commit/f053f778409932d55b95758c4b1516b63191d1eb
- https://github.com/ImageMagick/ImageMagick6/commit/61024a2677a3c7973a2dd27170877d8e51419473
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-32
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-57
More Imagemagick vulnerabilities
- TI-2016-03144 The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT… KEVCVSS 3.1HIGH 8.4
- TI-2023-16996 Improper input validation in ImageMagick CVSS 3.1CRITICAL 9.8
- TI-2016-03148 The (1) HTTP and (2) FTP coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1… KEVCVSS 3.1MEDIUM 5.5
- TI-2016-03145 The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote… KEVCVSS 3.1MEDIUM 5.5
- TI-2025-35690 ImageMagick BlobStream Forward-Seek Under-Allocation CVSS 3.1CRITICAL 9.8
- TI-2025-33094 ImageMagick has Stack Buffer Overflow in image.c CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-106567 · CVE Program
- CVE-2026-106567 · NVD
- FIRST EPSS
- CVE-2026-106567 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences