Code injection in ImageMagick postscript coders
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-94.
Summary
ImageMagick versions before 6.9.13-56 and from 7.0.0 before 7.1.2-31 are affected. Unescaped or untrimmed values let attackers inject code into output generated by PostScript coders (CWE-94). A remote attacker without privileges needs a user to interact with the software, which can lead to high confidentiality impact.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-31 and 6.9.13-56, unescaped or untrimmed values can inject code into output generated by PostScript coders. This issue is fixed in versions 7.1.2-31 and 6.9.13-56.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ImageMagick | ImageMagick | before 6.9.13-56; 7.0.0 to before 7.1.2-31 | 6.9.13-56, 7.1.2-31 | Patch available | CNA |
- ImageMagick VendorImageMagick Affected before 6.9.13-56; 7.0.0 to before 7.1.2-31 Fixed in 6.9.13-56, 7.1.2-31 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* | before 6.9.13-56; 7.0.0-0 to before 7.1.2-31 | Vulnerable | ImageMagick |
- cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* Versions before 6.9.13-56; 7.0.0-0 to before 7.1.2-31 Vulnerable ·ImageMagick
Remediation
Fixed in ImageMagick 7.1.2-31 for the 7.x line and 6.9.13-56 for the 6.x line. Red Hat Enterprise Linux 6 has no fix planned (no_fix_planned) and Red Hat Enterprise Linux 7 has none available (none_available).
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA ImageMagick (ImageMagick) Fixed in 6.9.13-56, 7.1.2-31
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-07 Threatist record created from CVE-2026-106577
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-08 Affected versions changed · Red Hat
- 2026-10-08 CVSS score added · Red Hat
- 2026-10-21 CVSS score added · NVD
References
Patch 6
- https://github.com/ImageMagick/ImageMagick/commit/2ba2edfd04a1ab3d45af4a0dc1e640dde7020192
- https://github.com/ImageMagick/ImageMagick/commit/78378cd623468760bee82a5930cb3011725916f8
- https://github.com/ImageMagick/ImageMagick6/commit/879489740daa44dd72e9405b26c845e8aa3d2f53
- https://github.com/ImageMagick/ImageMagick6/commit/d5750d7309ef5a8cd561430d932a183e4168f484
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-31
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-56
More Imagemagick vulnerabilities
- TI-2016-03144 The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT… KEVCVSS 3.1HIGH 8.4
- TI-2023-16996 Improper input validation in ImageMagick CVSS 3.1CRITICAL 9.8
- TI-2016-03148 The (1) HTTP and (2) FTP coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1… KEVCVSS 3.1MEDIUM 5.5
- TI-2016-03145 The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote… KEVCVSS 3.1MEDIUM 5.5
- TI-2025-35690 ImageMagick BlobStream Forward-Seek Under-Allocation CVSS 3.1CRITICAL 9.8
- TI-2025-33094 ImageMagick has Stack Buffer Overflow in image.c CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-106577 · CVE Program
- CVE-2026-106577 · NVD
- FIRST EPSS
- CVE-2026-106577 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences