Apache Jackrabbit DavEx client can instantiate arbitrary classes
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Apache Jackrabbit from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4 and from 2.20.0 through 2.20.17 has a flaw in its DavEx client where external input selects classes to instantiate (CWE-470). A malicious WebDAV/DavEx server, or an attacker intercepting the connection, can make the client instantiate arbitrary classes from its classpath, enabling arbitrary file creation or truncation. Only applications using jackrabbit-spi2dav, directly or through jackrabbit-jcr2dav, are affected.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Jackrabbit | 2.23.0 – 2.23.5; 2.22.0 – 2.22.4; 2.20.0 – 2.20.17 | — | No fix listed | CNA |
- Apache Jackrabbit VendorApache Affected 2.23.0 – 2.23.5; 2.22.0 – 2.22.4; 2.20.0 – 2.20.17 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:jackrabbit:*:*:*:*:*:*:*:* | 2.20.0 to before 2.20.18; 2.22.0 to before 2.22.5; 2.23.0 to before 2.23.6 | Vulnerable | Apache |
- cpe:2.3:a:apache:jackrabbit:*:*:*:*:*:*:*:* Versions 2.20.0 to before 2.20.18; 2.22.0 to before 2.22.5; 2.23.0 to before 2.23.6 Vulnerable ·Apache
Remediation
Upgrade Apache Jackrabbit to version 2.23.6, 2.22.5 or 2.20.18, which fix the issue.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Timeline
- 2026-10-07 Threatist record created from CVE-2026-92415
- 2026-10-07 Alias added: GHSA-f7m4-mw9m-xwg5
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-07 Priority changed: MEDIUM → LOW
- 2026-10-13 CVSS score added · NVD
References
More Apache Jackrabbit vulnerabilities
- TI-2015-01646 XML external entity (XXE) vulnerability in Apache Jackrabbit before 2.0.6, 2.2.x before… CVSS 2.0MEDIUM 6.4
- TI-2023-19328 Apache Jackrabbit RMI access can lead to RCE CVSS 3.1CRITICAL 9.8
- TI-2026-69192 Session hijacking in Apache Jackrabbit WebDAV server CVSS 4.0CRITICAL 9.3
- TI-2016-05842 Cross-site request forgery (CSRF) vulnerability in the CSRF content-type check in… CVSS 3.0HIGH 8.8
- TI-2009-00026 Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2… CVSS 2.0MEDIUM 4.3
- TI-2025-33606 Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons CVSS 3.1HIGH 8.8
Sources
- CVE-2026-92415 · CVE Program
- CVE-2026-92415 · NVD
- FIRST EPSS
- GHSA-f7m4-mw9m-xwg5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences