Policy bypass in ImageMagick MAT decoder with highly compressed data
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
ImageMagick versions before 6.9.13-55 and from 7.0.0 before 7.1.2-30 are affected. The MAT decoder mishandles highly compressed data (CWE-409), so it can create temporary files larger than the configured security-policy limit. An unauthenticated remote attacker can supply a crafted MAT image to bypass resource restrictions and consume excessive disk space.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-30 and 6.9.13-55, a crafted highly compressed MAT image can make the MAT decoder create temporary files larger than the configured security-policy limit, bypassing resource restrictions and consuming excessive disk space. This issue is fixed in versions 7.1.2-30 and 6.9.13-55.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ImageMagick | ImageMagick | before 6.9.13-55; 7.0.0 to before 7.1.2-30 | 6.9.13-55, 7.1.2-30 | Patch available | CNA |
- ImageMagick VendorImageMagick Affected before 6.9.13-55; 7.0.0 to before 7.1.2-30 Fixed in 6.9.13-55, 7.1.2-30 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* | before 6.9.13-55; 7.0.0-0 to before 7.1.2-30 | Vulnerable | ImageMagick |
- cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* Versions before 6.9.13-55; 7.0.0-0 to before 7.1.2-30 Vulnerable ·ImageMagick
Remediation
Upgrade ImageMagick to version 7.1.2-30 or 6.9.13-55, which fix this issue. Red Hat lists its plan for Red Hat Enterprise Linux 6 as no fix planned and for Red Hat Enterprise Linux 7 as none available.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA ImageMagick (ImageMagick) Fixed in 6.9.13-55, 7.1.2-30
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-07 Threatist record created from CVE-2026-107210
- 2026-10-08 Affected versions changed · Red Hat
- 2026-10-08 CVSS score added · Red Hat
- 2026-10-10 CISA SSVC decision points changed
References
Patch 4
- https://github.com/ImageMagick/ImageMagick/commit/ae2ed8c81d8fad1f186e7f2bc0837b46a1c7be61
- https://github.com/ImageMagick/ImageMagick6/commit/7d8e0eb11804a5ce5322ea317dfd3557cded4e7b
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-30
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-55
More Imagemagick vulnerabilities
- TI-2016-03144 The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT… KEVCVSS 3.1HIGH 8.4
- TI-2023-16996 Improper input validation in ImageMagick CVSS 3.1CRITICAL 9.8
- TI-2016-03148 The (1) HTTP and (2) FTP coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1… KEVCVSS 3.1MEDIUM 5.5
- TI-2016-03145 The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote… KEVCVSS 3.1MEDIUM 5.5
- TI-2025-35690 ImageMagick BlobStream Forward-Seek Under-Allocation CVSS 3.1CRITICAL 9.8
- TI-2025-33094 ImageMagick has Stack Buffer Overflow in image.c CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-107210 · CVE Program
- CVE-2026-107210 · NVD
- FIRST EPSS
- CVE-2026-107210 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences