Improper access control in Splunk Secure Gateway REST API endpoints
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-284.
Summary
Splunk Enterprise versions before 10.4.3, 10.2.7, 10.0.10 and 9.4.15, and Splunk Secure Gateway versions before 3.10.11, 3.9.25 and 3.8.72, are affected. Multiple Splunk Secure Gateway REST API endpoints do not enforce authorization before processing requests, which is classified as CWE-284. A user without the admin or power Splunk role can reach privileged Secure Gateway functionality and cause it to sign attacker-controlled payloads. An attacker needs a low-privileged account on the system.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, and Splunk Secure Gateway versions below 3.10.11, 3.9.25, and 3.8.72, a user who does not hold the "admin" or "power" Splunk roles could access privileged Splunk Secure Gateway functionality. With this access, the user could cause Splunk Secure Gateway to sign attacker-controlled payloads. The vulnerability is possible because multiple Splunk Secure Gateway Representational State Transfer (REST) API endpoints do not enforce authorization requirements before processing requests.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Splunk | Splunk Enterprise | 10.4 to before 10.4.3; 10.2 to before 10.2.7; 10.0 to before 10.0.10; 9.4 to before 9.4.15 | 10.4.3, 10.2.7, 10.0.10, 9.4.15 | Patch available | CNA |
| Splunk | Splunk Secure Gateway | 3.10 to before 3.10.11; 3.9 to before 3.9.25; 3.8 to before 3.8.72 | 3.10.11, 3.9.25, 3.8.72 | Patch available | CNA |
- Splunk Enterprise VendorSplunk Affected 10.4 to before 10.4.3; 10.2 to before 10.2.7; 10.0 to before 10.0.10; 9.4 to before 9.4.15 Fixed in 10.4.3, 10.2.7, 10.0.10, 9.4.15 Patch available CNA
- Splunk Secure Gateway VendorSplunk Affected 3.10 to before 3.10.11; 3.9 to before 3.9.25; 3.8 to before 3.8.72 Fixed in 3.10.11, 3.9.25, 3.8.72 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:* | 9.4.0 to before 9.4.15; 10.0.0 to before 10.0.10; 10.2.0 to before 10.2.7; 10.4.0 to before 10.4.3 | Vulnerable | Splunk |
| cpe:2.3:a:splunk:splunk_secure_gateway:*:*:*:*:*:*:*:* | 3.8.0 to before 3.8.72; 3.9.0 to before 3.9.25; 3.10.0 to before 3.10.11 | Vulnerable | Splunk |
- cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:* Versions 9.4.0 to before 9.4.15; 10.0.0 to before 10.0.10; 10.2.0 to before 10.2.7; 10.4.0 to before 10.4.3 Vulnerable ·Splunk
- cpe:2.3:a:splunk:splunk_secure_gateway:*:*:*:*:*:*:*:* Versions 3.8.0 to before 3.8.72; 3.9.0 to before 3.9.25; 3.10.0 to before 3.10.11 Vulnerable ·Splunk
Remediation
Upgrade Splunk Enterprise to 10.4.3, 10.2.7, 10.0.10 or 9.4.15, depending on the branch in use. Upgrade Splunk Secure Gateway to 3.10.11, 3.9.25 or 3.8.72, depending on the branch in use.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Splunk Enterprise (Splunk) Fixed in 10.4.3, 10.2.7, 10.0.10, 9.4.15
- Fix · CNA Splunk Secure Gateway (Splunk) Fixed in 3.10.11, 3.9.25, 3.8.72
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Splunk Enterprise 10.0.10, 10.2.7 and 2 more versions
14 records Highest priority Priority MEDIUM 3 MEDIUM, 11 LOW
Other records, highest priority first
- TI-2026-69309 Coding standard flaws in Splunk Enterprise allow remote attacksPriority MEDIUM 49
- TI-2026-69308 Improper Neutralization in Splunk EnterprisePriority MEDIUM 49
- TI-2026-69306 Resource lifetime control flaw in Splunk EnterprisePriority MEDIUM 40
- Release ·
Splunk Secure Gateway 3.10.11, 3.8.72, 3.9.25
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-69304 Incorrect Permission Assignment in Splunk Secure Gateway KV Store CollectionsPriority LOW 27
- TI-2026-69296 Missing authorization in Splunk Secure Gateway lets users sign dataPriority LOW 19
Timeline
- 2026-10-07 Threatist record created from CVE-2026-76265
- 2026-10-07 Alias added: GHSA-grm2-hfh8-7h22
- 2026-10-09 Priority changed: MEDIUM → LOW
- 2026-10-10 CISA SSVC decision points changed
References
More Splunk vulnerabilities
- TI-2026-16444 Unauthenticated Arbitrary File Creation and Truncation in a PostgreSQL Sidecar Service Endpoint in Splunk Enterprise KEVCVSS 3.1CRITICAL 9.8
- TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
- TI-2023-24841 Remote code execution (RCE) in Splunk Enterprise through Insecure XML Parsing CVSS 3.1HIGH 8.8
- TI-2023-15979 ‘edit_user’ Capability Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2024-30707 Remote Code Execution (RCE) due to insecure session storage configuration in Splunk Enterprise on Windows CVSS 3.1HIGH 8.8
- TI-2022-21345 Reflected Cross-Site Scripting via the radio template in Splunk Enterprise CVSS 3.1HIGH 8.8
Sources
- CVE-2026-76265 · CVE Program
- CVE-2026-76265 · NVD
- FIRST EPSS
- GHSA-grm2-hfh8-7h22 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences