Privilege escalation via Linux package upgrade in Splunk Enterprise
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
Splunk Enterprise on Linux is affected in versions from 10.4 before 10.4.3, from 10.2 before 10.2.7, from 10.0 before 10.0.10 and from 9.4 before 9.4.15. The Linux package maintainer script trusts existing installation content when it runs upgrade operations with root privileges (CWE-269). A local user who can run commands as the Splunk Enterprise user can modify the installation so that an affected package upgrade runs attacker-controlled operating system commands as root, provided the upgrade happens after the modification.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15 on Linux, a local user who can run commands as the user account running Splunk Enterprise could cause an affected Linux package upgrade to run attacker-controlled operating-system commands with root privileges. The vulnerability is possible because the Linux package maintainer script trusts existing Splunk Enterprise installation content when it performs upgrade operations with root privileges. The vulnerability requires an affected Linux package upgrade to occur after the local user modifies the installation. The local user should not be able to elevate privileges at will.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Splunk | Splunk Enterprise | 10.4 to before 10.4.3; 10.2 to before 10.2.7; 10.0 to before 10.0.10; 9.4 to before 9.4.15 | 10.4.3, 10.2.7, 10.0.10, 9.4.15 | Patch available | CNA |
- Splunk Enterprise VendorSplunk Affected 10.4 to before 10.4.3; 10.2 to before 10.2.7; 10.0 to before 10.0.10; 9.4 to before 9.4.15 Fixed in 10.4.3, 10.2.7, 10.0.10, 9.4.15 Patch available CNA
Remediation
Splunk Enterprise 10.4.3, 10.2.7, 10.0.10 and 9.4.15 fix the vulnerability, so upgrade to the fixed version for the release branch in use.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Splunk Enterprise (Splunk) Fixed in 10.4.3, 10.2.7, 10.0.10, 9.4.15
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Splunk Enterprise 10.0.10, 10.2.7 and 2 more versions
14 records Highest priority Priority MEDIUM 3 MEDIUM, 11 LOW
Other records, highest priority first
- TI-2026-69309 Coding standard flaws in Splunk Enterprise allow remote attacksPriority MEDIUM 49
- TI-2026-69308 Improper Neutralization in Splunk EnterprisePriority MEDIUM 49
- TI-2026-69306 Resource lifetime control flaw in Splunk EnterprisePriority MEDIUM 40
Timeline
- 2026-10-07 Threatist record created from CVE-2026-76266
- 2026-10-07 Alias added: GHSA-8pcj-88pc-fvhf
- 2026-10-08 CISA SSVC decision points changed
- 2026-10-08 Priority changed: MEDIUM → LOW
- 2026-10-09 CISA SSVC decision points changed
References
More Splunk vulnerabilities
- TI-2026-16444 Unauthenticated Arbitrary File Creation and Truncation in a PostgreSQL Sidecar Service Endpoint in Splunk Enterprise KEVCVSS 3.1CRITICAL 9.8
- TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
- TI-2023-24841 Remote code execution (RCE) in Splunk Enterprise through Insecure XML Parsing CVSS 3.1HIGH 8.8
- TI-2023-15979 ‘edit_user’ Capability Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2024-30707 Remote Code Execution (RCE) due to insecure session storage configuration in Splunk Enterprise on Windows CVSS 3.1HIGH 8.8
- TI-2022-21345 Reflected Cross-Site Scripting via the radio template in Splunk Enterprise CVSS 3.1HIGH 8.8
Sources
- CVE-2026-76266 · CVE Program
- CVE-2026-76266 · NVD
- FIRST EPSS
- GHSA-8pcj-88pc-fvhf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences