Read the docs
TI-2026-69374 Aliases CVE-2026-5048GHSA-8gcr-rfxc-ph8p

SQL injection in Brocade SANnav external API inventories

Priority LOW 27CWE-89Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
SQL injection
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.

Summary

Brocade SANnav versions from 0 before 3.0.0a contain an SQL injection flaw (CWE-89) in various external API inventories. An authenticated attacker can inject malicious data into some REST API query parameters, which the software passes into SQL commands. The CVSS 4.0 vector shows low privileges are required, the attack is over an adjacent network, and the main effect is on the subsequent system, with high confidentiality impact there.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

In Brocade SANnav before 3.0.0a, an SQL Injection vulnerability in various external API inventories have a vulnerability that allows an authenticated attacker to inject malicious data into some of the REST API -query parameters.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00231 13th percentileScored 2026-11-07
Fix Fixed Brocade SANnav (Brocade): 3.0.0a

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
BrocadeBrocade SANnavbefore 3.0.0a3.0.0aPatch availableCNA
  • Brocade SANnav VendorBrocade Affected before 3.0.0a Fixed in 3.0.0a Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:broadcom:brocade_sannav:*:*:*:*:*:*:*:*before 3.0.0aVulnerableBroadcom
  • cpe:2.3:a:broadcom:brocade_sannav:*:*:*:*:*:*:*:* Versions before 3.0.0a Vulnerable ·Broadcom

Remediation

Upgrade Brocade SANnav to version 3.0.0a or later, which fixes this issue.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA Brocade SANnav (Brocade) Fixed in 3.0.0a

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Brocade SANnav 3.0.0a

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2026-69375 Path traversal in Brocade SANnav Zone Alias Import flowPriority LOW 30

Timeline

  1. 2026-10-08 Threatist record created from CVE-2026-5048
  2. 2026-10-08 CISA SSVC decision points changed
  3. 2026-10-08 Priority changed: MEDIUM → LOW
  4. 2026-10-15 Alias added: GHSA-8gcr-rfxc-ph8p
  5. 2026-10-15 CVSS score added · NVD

References

  • TI-2025-01721 Code injection exposure in Fabric OS 9.1.0 through 9.1.1d6 KEVCVSS 4.0HIGH 8.6
  • TI-2016-06760 Path traversal in Brocade Network Advisor versions released prior to and including 14.0.2 CVSS 3.0CRITICAL 9.8
  • TI-2024-19729 hard-coded credentials in the documentation that appear as the appliance root password CVSS 3.1CRITICAL 9.8
  • TI-2016-06762 Path traversal in Brocade Network Advisor versions released prior to and including 14.0.2 CVSS 3.0HIGH 7.5
  • TI-2018-04739 OS command injection in Brocade Network Advisor CVSS 3.0CRITICAL 9.8
  • TI-2016-06761 Path traversal in Brocade Network Advisor versions released prior to and including 14.0.2 CVSS 3.0HIGH 7.5
See all 191 →

Sources