Unauthenticated stored XSS in GPTranslate WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The GPTranslate WordPress plugin before 2.34.14 does not restrict who can store translations and does not escape them when outputting them in translated pages (CWE-79). An unauthenticated remote attacker can store script that runs in visitors' browsers when server-side translations are enabled. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The GPTranslate WordPress plugin before 2.34.14 does not properly restrict who can store translations, and does not escape them when outputting them in translated pages, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks when server-side translations are enabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | GPTranslate | before 2.34.14 | 2.34.14 | Patch available | CNA |
- GPTranslate VendorUnknown Affected before 2.34.14 Fixed in 2.34.14 Patch available CNA
Remediation
Update GPTranslate to version 2.34.14, which is the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA GPTranslate (Unknown) Fixed in 2.34.14
Timeline
- 2026-10-08 Threatist record created from CVE-2026-103309
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences