Read the docs

MariaDB Connector/Node.js crashes on ed25519 authentication with TLS

Priority LOW 26CWE-248Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-248.

Summary

From 3.3.0 before 3.5.4, MariaDB Connector/Node.js and the mariadb npm package have a flaw in zero-configuration TLS fingerprint validation, where Ed25519PasswordAuth.hash() references a seed identifier that is not in scope (CWE-248). A malicious server or a network attacker presenting a self-signed certificate can trigger it when client_ed25519 authentication is negotiated over TLS without a configured CA. The resulting uncaught ReferenceError terminates the client process under default Node.js behavior, causing denial of service.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

Description from the CNA

MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. From 3.3.0 until 3.5.4, the zero-configuration TLS fingerprint-validation path calls Ed25519PasswordAuth.hash() through Authentication.validateFingerPrint, but Ed25519PasswordAuth.hash() references a seed identifier that is not in scope. Exposure requires a MariaDB server reached over TCP, TLS enabled with ssl: true or an ssl object whose rejectUnauthorized value is not false, a password set, no ssl.ca configured, and client_ed25519 negotiated as the authentication plugin. Under those conditions, a legitimate server, malicious server, or network attacker presenting a self-signed certificate can reach this path and cause a synchronous ReferenceError to escape the socket data handler. Under Node.js default uncaught-exception behavior, the client process terminates, causing denial of service. Configurations using a provided CA, rejectUnauthorized: false, another authentication plugin, or a Unix socket do not reach this vulnerable path. This issue is fixed in version 3.5.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00235 14th percentileScored 2026-11-07
Fix Fixed mariadb-connector-nodejs (mariadb-corporation): 3.5.4mariadb (npm): 3.5.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MariaDBmariadb-connector-nodejs3.3.0 to before 3.5.43.5.4Patch availableCNA
—mariadb (npm)3.3.0 to before 3.5.43.5.4Patch availableGHSA-cx2f-j9fh-8g68
  • mariadb-connector-nodejs VendorMariaDB Affected 3.3.0 to before 3.5.4 Fixed in 3.5.4 Patch available CNA
  • mariadb (npm) Vendor— Affected 3.3.0 to before 3.5.4 Fixed in 3.5.4 Patch available GHSA-cx2f-j9fh-8g68

Remediation

Upgrade mariadb-connector-nodejs and the mariadb npm package to version 3.5.4.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

  • Fix · CNA mariadb-connector-nodejs (mariadb-corporation) Fixed in 3.5.4
  • Fix · GHSA-cx2f-j9fh-8g68 mariadb (npm) Fixed in 3.5.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-09 Threatist record created from CVE-2026-107382
  2. 2026-10-09 Alias added: GHSA-cx2f-j9fh-8g68
  3. 2026-11-06 Affected versions changed · Red Hat
  4. 2026-11-06 CVSS score added · Red Hat

References

  • TI-2023-11776 MariaDB v10.5 was discovered to contain a remote code execution (RCE) vulnerability via… CVSS 3.1CRITICAL 9.8
  • TI-2016-05707 Oracle MySQL through 5.5.52, 5.6.x through 5.6.33, and 5.7.x through 5.7.15; MariaDB… CVSS 3.0CRITICAL 9.8
  • TI-2022-00687 Infinite loop in BN_mod_sqrt() reachable when parsing certificates CVSS 3.1HIGH 7.5
  • TI-2014-00217 OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly… CVSS 3.1HIGH 7.4
  • TI-2014-00188 The dtls1_reassemble_fragment function in d1_both.c in OpenSSL before 0.9.8za, 1.0.0… CVSS 2.0MEDIUM 6.8
  • TI-2018-15259 zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if… CVSS 3.1HIGH 7.5
See all 459 →

Sources