SQL injection in MariaDB Connector/Node.js through SET object keys
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
MariaDB Connector/Node.js from 3.2.0 before 3.2.5, from 3.3.0 before 3.3.4, from 3.4.0 before 3.4.7, and from 3.5.0-rc.0 before 3.5.4 expands object keys into a SQL SET clause without escaping them when permitSetMultiParamEntries is enabled. A key containing a backtick can close the quoted identifier, which is an SQL injection flaw (CWE-89). A remote attacker who controls the object keys can update columns the application did not intend to expose or append arbitrary SQL with the database user's privileges.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. From 3.2.0 until 3.2.5, 3.3.4, 3.4.7, and 3.5.4, applications that enable permitSetMultiParamEntries can pass objects whose keys are expanded into a SQL SET clause without being processed by escapeId. An attacker-controlled key containing a backtick can close the quoted identifier and cause the remainder of the key to be interpreted as SQL. This can update columns the application did not intend to expose and can append arbitrary SQL with the database user's privileges. The option is disabled by default, and serialized-object handling used when it is disabled is not affected. This issue is fixed in versions 3.2.5, 3.3.4, 3.4.7, and 3.5.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MariaDB | mariadb-connector-nodejs | 3.2.0 to before 3.2.5; 3.3.0 to before 3.3.4; 3.4.0 to before 3.4.7; 3.5.0-rc.0 to before 3.5.4 | 3.2.5, 3.3.4, 3.4.7, 3.5.4 | Patch available | CNA |
| — | mariadb (npm) | 3.2.0 to before 3.2.5 | 3.2.5 | Patch available | GHSA-v6pj-gxxw-phfw |
| — | mariadb (npm) | 3.3.0 to before 3.3.4 | 3.3.4 | Patch available | GHSA-v6pj-gxxw-phfw |
| — | mariadb (npm) | 3.4.0 to before 3.4.7 | 3.4.7 | Patch available | GHSA-v6pj-gxxw-phfw |
| — | mariadb (npm) | 3.5.0-rc.0 to before 3.5.4 | 3.5.4 | Patch available | GHSA-v6pj-gxxw-phfw |
- mariadb-connector-nodejs VendorMariaDB Affected 3.2.0 to before 3.2.5; 3.3.0 to before 3.3.4; 3.4.0 to before 3.4.7; 3.5.0-rc.0 to before 3.5.4 Fixed in 3.2.5, 3.3.4, 3.4.7, 3.5.4 Patch available CNA
- mariadb (npm) Vendor— Affected 3.2.0 to before 3.2.5 Fixed in 3.2.5 Patch available GHSA-v6pj-gxxw-phfw
- mariadb (npm) Vendor— Affected 3.3.0 to before 3.3.4 Fixed in 3.3.4 Patch available GHSA-v6pj-gxxw-phfw
- mariadb (npm) Vendor— Affected 3.4.0 to before 3.4.7 Fixed in 3.4.7 Patch available GHSA-v6pj-gxxw-phfw
- mariadb (npm) Vendor— Affected 3.5.0-rc.0 to before 3.5.4 Fixed in 3.5.4 Patch available GHSA-v6pj-gxxw-phfw
Remediation
Upgrade mariadb-connector-nodejs to 3.2.5, 3.3.4, 3.4.7, or 3.5.4, matching the release line in use. The npm package mariadb is fixed in the same versions.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA mariadb-connector-nodejs (mariadb-corporation) Fixed in 3.2.5, 3.3.4, 3.4.7, 3.5.4
- Fix · GHSA-v6pj-gxxw-phfw mariadb (npm) Fixed in 3.2.5 Advisory →
- Fix · GHSA-v6pj-gxxw-phfw mariadb (npm) Fixed in 3.3.4 Advisory →
- Fix · GHSA-v6pj-gxxw-phfw mariadb (npm) Fixed in 3.4.7 Advisory →
- Fix · GHSA-v6pj-gxxw-phfw mariadb (npm) Fixed in 3.5.4 Advisory →
Vendor assessments
Timeline
- 2026-10-09 Threatist record created from CVE-2026-107384
- 2026-10-09 Alias added: GHSA-v6pj-gxxw-phfw
- 2026-10-10 CISA SSVC decision points changed
- 2026-10-10 Priority changed: MEDIUM → LOW
- 2026-11-06 Affected versions changed · Red Hat
- 2026-11-06 CVSS score added · Red Hat
References
Other 12
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/security/advisories/GHSA-v6pj-gxxw-phfw
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/commit/144b8f4ef29539a9fb4b75d972b9dcdac4088b4e
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/commit/6743b2f4a89b074268b44c650170767f35e1fb5d
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/commit/8eb450972ff0f3826d7d45c071a42240798bc826
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/commit/b9b04ec82a60b2caf2b0c038259ca9aff5d7014a
- https://hackerone.com/reports/3889198
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/releases/tag/3.2.5
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/releases/tag/3.3.4
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/releases/tag/3.4.7
- https://github.com/mariadb-corporation/mariadb-connector-nodejs/releases/tag/3.5.4
- https://jira.mariadb.org/browse/CONJS-369
- https://github.com/mariadb-corporation/mariadb-connector-nodejs
More MariaDB vulnerabilities
- TI-2023-11776 MariaDB v10.5 was discovered to contain a remote code execution (RCE) vulnerability via… CVSS 3.1CRITICAL 9.8
- TI-2016-05707 Oracle MySQL through 5.5.52, 5.6.x through 5.6.33, and 5.7.x through 5.7.15; MariaDB… CVSS 3.0CRITICAL 9.8
- TI-2022-00687 Infinite loop in BN_mod_sqrt() reachable when parsing certificates CVSS 3.1HIGH 7.5
- TI-2014-00217 OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly… CVSS 3.1HIGH 7.4
- TI-2014-00188 The dtls1_reassemble_fragment function in d1_both.c in OpenSSL before 0.9.8za, 1.0.0… CVSS 2.0MEDIUM 6.8
- TI-2018-15259 zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if… CVSS 3.1HIGH 7.5
Sources
- CVE-2026-107384 · CVE Program
- CVE-2026-107384 · NVD
- FIRST EPSS
- GHSA-v6pj-gxxw-phfw · GitHub Advisory Database · CC BY 4.0
- CVE-2026-107384 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences