Heap buffer overflow in MongoDB PHP Driver BSON encoder
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
MongoDB PHP Driver versions from 1.16.0 before 1.21.11, from 2.0.0 before 2.1.11, and from 2.2.0 before 2.5.4 are affected. The BSON encoder converts a string length to a 32-bit value without validation (CWE-681), so the allocation size can wrap while the copy uses the original length. A local user with low privileges can trigger a heap buffer overflow when an affected application encodes a string near 4 GiB under a non-default runtime configuration that permits multi-gigabyte values. The overflow can corrupt process memory or terminate the PHP process, and no MongoDB server interaction is required.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The BSON encoder in the MongoDB PHP Driver converts a string length to a 32-bit value without validation. When an affected application encodes a string near 4 GiB, the allocation size can wrap while the copy operation uses the original length. The resulting heap buffer overflow can corrupt process memory or terminate the PHP process. Reaching this issue requires a non-default runtime configuration that permits multi-gigabyte values. No MongoDB server interaction is required.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | PHP Driver | 1.16.0 to before 1.21.11; 2.0.0 to before 2.1.11; 2.2.0 to before 2.5.4 | 1.21.11, 2.1.11, 2.5.4 | Patch available | CNA |
- PHP Driver VendorMongoDB Affected 1.16.0 to before 1.21.11; 2.0.0 to before 2.1.11; 2.2.0 to before 2.5.4 Fixed in 1.21.11, 2.1.11, 2.5.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:php_driver:*:*:*:*:*:mongodb:*:* | 1.3.0 to before 1.21.1; 2.0.0 to before 2.1.11; 2.2.0 to before 2.5.4 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:php_driver:*:*:*:*:*:mongodb:*:* Versions 1.3.0 to before 1.21.1; 2.0.0 to before 2.1.11; 2.2.0 to before 2.5.4 Vulnerable ·MongoDB
Remediation
Upgrade MongoDB PHP Driver to version 1.21.11, 2.1.11 or 2.5.4, depending on the release branch in use.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA PHP Driver (MongoDB) Fixed in 1.21.11, 2.1.11, 2.5.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
MongoDB PHP Driver 1.21.11, 2.1.11, 2.5.4
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-69733 Unchecked BSON encoder return values in MongoDB PHP DriverPriority LOW 28
Vendor assessments
Timeline
- 2026-10-09 Threatist record created from CVE-2026-106432
- 2026-10-10 Affected versions changed · Red Hat
- 2026-10-10 CVSS score added · Red Hat
- 2026-10-13 CVSS score added · NVD
References
More MongoDB Php Driver vulnerabilities
- TI-2026-56246 Cross-tenant database retargeting via dot/NUL injection in namespace strings in the PHP Driver CVSS 4.0HIGH 8.6
- TI-2026-58391 Heap out-of-bounds read via corrupt nested BSON in field path error message CVSS 4.0MEDIUM 6.9
- TI-2024-07001 Accessing Untrusted Directory May Allow Local Privilege Escalation CVSS 3.1HIGH 7.8
- TI-2021-12015 Information disclosure in MongoDB C Driver CVSS 3.1HIGH 7.5
- TI-2025-11114 Bulk write with options may read invalid memory CVSS 4.0MEDIUM 6.9
- TI-2026-69733 Unchecked BSON encoder return values in MongoDB PHP Driver CVSS 4.0MEDIUM 6.3
Sources
- CVE-2026-106432 · CVE Program
- CVE-2026-106432 · NVD
- FIRST EPSS
- CVE-2026-106432 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences