Backdrop CMS does not sufficiently protect configuration exports
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Backdrop CMS from 1.34.0 before 1.34.5 and from 1.35.0 before 1.35.1 does not sufficiently protect configuration exports delivered as compressed archives. Config.admin.inc does not ensure a file_unmanaged_delete operation occurs, so old archives such as config.tar.gz could persist (CWE-459). A local attacker with no privileges can exploit it with high complexity, though an export must first be requested by a user with the Synchronize, import, and export configuration permission.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Backdrop CMS 1.34 before 1.34.5 and 1.35 before 1.35.1 doesn't sufficiently protect configuration exports when delivering a compressed archive. This vulnerability is mitigated by the fact that an export must have been previously requested by someone with the "Synchronize, import, and export configuration" permission. NOTE: CVE-2026-107914 refers to the vulnerability in which config.admin.inc does not ensure that a file_unmanaged_delete operation occurs. Therefore, many archives could persist: config.tar.gz, config_0.tar.gz, config_1.tar.gz, etc. There is a separate config.module issue that could allow remote access by an anonymous user, but only for the one filename config.tar.gz.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backdropcms | Backdrop | 1.34.0 to before 1.34.5; 1.35.0 to before 1.35.1 | 1.34.5, 1.35.1 | Patch available | CNA |
- Backdrop Vendorbackdropcms Affected 1.34.0 to before 1.34.5; 1.35.0 to before 1.35.1 Fixed in 1.34.5, 1.35.1 Patch available CNA
Remediation
Update Backdrop to 1.34.5 for the 1.34 branch or to 1.35.1 for the 1.35 branch.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Backdrop (backdropcms) Fixed in 1.34.5, 1.35.1
Timeline
- 2026-10-09 Threatist record created from CVE-2026-107914
- 2026-10-09 Alias added: GHSA-rcrw-452r-xvqv
- 2026-10-10 Priority changed: MEDIUM → LOW
- 2026-10-14 CISA SSVC decision points changed
References
More backdropcms vulnerabilities
- TI-2019-08480 jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles… CVSS 3.1MEDIUM 6.1
- TI-2025-39465 Host Header Injection vulnerability in Backdrop CMS 1.32.1 allows attackers to manipulate… CVSS 3.1MEDIUM 6.1
- TI-2023-14781 A stored Cross-site scripting (XSS) issue in Text Editors and Formats in Backdrop CMS… CVSS 3.1MEDIUM 4.8
- TI-2022-20387 Backdrop CMS version 1.23.0 was discovered to contain a stored cross-site scripting (XSS) vulnerability via 'Comment.' . CVSS 3.1MEDIUM 4.8
- TI-2022-20386 Backdrop CMS version 1.23.0 was discovered to contain a stored cross-site scripting (XSS)… CVSS 3.1MEDIUM 4.8
- TI-2022-20385 Backdrop CMS version 1.23.0 was discovered to contain a stored cross-site scripting (XSS)… CVSS 3.1MEDIUM 4.8
Sources
- CVE-2026-107914 · CVE Program
- CVE-2026-107914 · NVD
- FIRST EPSS
- GHSA-rcrw-452r-xvqv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences