SQL injection in WordPress Post Author plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The wp-post-author plugin for WordPress, versions from 4.0.0 before 4.1.0, contains an SQL injection flaw (CWE-89) caused by improper neutralization of special elements in an SQL command. An authenticated attacker with low privileges can read data from the database. The CVSS 4.0 vector shows high confidentiality impact with no integrity or availability impact.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Improper neutralization of special elements used in an SQL command ('SQL injection') vulnerability in wp-post-author. This issue affects wp-post-author version 4.0.0 prior to 4.1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | wp-post-author | 4.0.0 to before 4.1.0 | 4.1.0 | Patch available | CNA |
- wp-post-author Vendor— Affected 4.0.0 to before 4.1.0 Fixed in 4.1.0 Patch available CNA
Remediation
Update wp-post-author to version 4.1.0 or later, which fixes the issue. The sources list no further advisory identifiers for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA wp-post-author Fixed in 4.1.0
Timeline
- 2026-10-09 Threatist record created from CVE-2026-108125
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences