Stored cross-site scripting in Robo Gallery WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Robo Gallery WordPress plugin before 5.2.6 does not sanitise or escape a gallery setting before printing it on a frontend page, which is cross-site scripting (CWE-79). A user with the Author role or higher can store script that runs in the browser of any visitor who views a gallery, including administrators. The references include an exploit link.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The Robo Gallery WordPress plugin before 5.2.6 does not sanitise and escape a gallery setting before outputting it on a frontend page, allowing users with the Author role and above to perform Stored Cross-Site Scripting attacks that execute in the browser of any visitor viewing a gallery, including administrators.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Robo Gallery | before 5.2.6 | 5.2.6 | Patch available | CNA |
- Robo Gallery VendorUnknown Affected before 5.2.6 Fixed in 5.2.6 Patch available CNA
Remediation
Update the Robo Gallery plugin to version 5.2.6, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Robo Gallery (Unknown) Fixed in 5.2.6
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Robo Gallery 5.2.6
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2026-70446 Stored XSS in Robo Gallery WordPress plugin gallery settingsPriority LOW 32
- TI-2026-70444 Stored cross-site scripting in Robo Gallery WordPress plugin via image alt textPriority LOW 32
- TI-2026-70443 Stored cross-site scripting in Robo Gallery via image overlay effect metaPriority LOW 32
Timeline
- 2026-10-11 Threatist record created from CVE-2026-81155
- 2026-10-11 Alias added: GHSA-fpmp-8c24-ggh8
References
Sources
- CVE-2026-81155 · CVE Program
- CVE-2026-81155 · NVD
- FIRST EPSS
- GHSA-fpmp-8c24-ggh8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences