Missing authorization in Insurify plugin lets anyone overwrite options
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
CVE-2026-85121 is a missing authorization flaw (CWE-862) in the Insurify WordPress plugin through 1.0. One AJAX action lacks authorisation and nonce checks, so unauthenticated users can create and overwrite arbitrary WordPress options with request data. The CVSS 3.1 base score is 9.1 (CRITICAL), and the attack can take the site offline and deactivate its plugins.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The Insurify WordPress plugin through 1.0 does not have authorisation and nonce checks on one of its AJAX actions, allowing unauthenticated users to create and overwrite arbitrary WordPress options with request data, which can take the site offline and deactivate all of its Insurify WordPress plugin through 1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Insurify | up to 1.0 | — | No fix listed | CNA |
- Insurify VendorUnknown Affected up to 1.0 Fixed in — No fix listed CNA
Remediation
No fixed version is listed for Insurify 1.0 or earlier. Deactivate the plugin until a fixed release is available, and check the site's options for unexpected entries.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Timeline
- 2026-10-11 Threatist record created from CVE-2026-85121
- 2026-10-11 Alias added: GHSA-v69x-x643-f98h
References
Sources
- CVE-2026-85121 · CVE Program
- CVE-2026-85121 · NVD
- FIRST EPSS
- GHSA-v69x-x643-f98h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences