SQL injection in highwarden Super Store Finder index.php
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
highwarden Super Store Finder from 3.0 before 3.9 is affected. The lat/lng argument of the /products/superstorefinder/index.php file is not neutralized before it is used in an SQL command, which allows SQL injection (CWE-89). A remote attacker with low privileges can exploit this flaw. The exploit has been publicly disclosed.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
A vulnerability has been found in highwarden Super Store Finder up to 3.8. Affected is an unknown function of the file /products/superstorefinder/index.php. The manipulation of the argument lat/lng leads to sql injection. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 3.9 is able to address this issue. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| highwarden | Super Store Finder | 3.0; 3.1; 3.2; 3.3; 3.4; 3.5; 3.6; 3.7; 3.8 | 3.9 | Patch available | CNA |
- Super Store Finder Vendorhighwarden Affected 3.0; 3.1; 3.2; 3.3; 3.4; 3.5; 3.6; 3.7; 3.8 Fixed in 3.9 Patch available CNA
CPE names CNA · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:highwarden:super_store_finder:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:highwarden:super_store_finder:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
Upgrade highwarden Super Store Finder to version 3.9, the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Super Store Finder (highwarden) Fixed in 3.9
Timeline
- 2026-10-11 Threatist record created from CVE-2026-108541
- 2026-10-11 Alias added: GHSA-5949-23g3-9j6v
- 2026-10-13 CISA SSVC decision points changed
- 2026-10-13 Priority changed: LOW → MEDIUM
References
More highwarden vulnerabilities
- TI-2023-21998 A hard coded password in Super Store Finder v3.6 allows attackers to access the administration panel. CVSS 3.1CRITICAL 9.8
- TI-2023-21997 Super Store Finder v3.6 was discovered to contain multiple SQL injection vulnerabilities… CVSS 3.1CRITICAL 9.8
- TI-2023-20178 SQL injection vulnerability in Super Store Finder PHP Script v.3.6 allows a remote… CVSS 3.1CRITICAL 9.8
- TI-2023-23515 Super Store Finder 3.7 and below is vulnerable to authenticated Arbitrary PHP Code… CVSS 3.1HIGH 8.8
- TI-2023-23625 Super Store Finder v3.6 and below was discovered to contain a SQL injection vulnerability… CVSS 3.1HIGH 7.2
- TI-2024-29567 WordPress Super Store Finder plugin < 6.9.8 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-108541 · CVE Program
- CVE-2026-108541 · NVD
- FIRST EPSS
- GHSA-5949-23g3-9j6v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences