Input validation flaw in Samsung Internet allows script injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Samsung Internet before 30.0.5.24 contains an improper input validation flaw. A remote attacker can inject arbitrary script, and user interaction is required to trigger it. The CVSS vector rates the impact on confidentiality as high.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Improper input validation in Samsung Internet prior to version 30.0.5.24 allows remote attackers to inject arbitrary script. User interaction is required for triggering this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update Samsung Internet to version 30.0.5.24, which fixes this issue.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Samsung Internet (Samsung Mobile) Fixed in 30.0.5.24
Timeline
- 2026-10-12 Threatist record created from CVE-2026-21132
- 2026-10-12 Alias added: GHSA-6mm7-m528-46x8
- 2026-10-12 Priority changed: MEDIUM → LOW
- 2026-10-16 CISA SSVC decision points changed
More Samsung vulnerabilities
- TI-2025-15039 Out-of-bounds write in Samsung Mobile Devices KEVCVSS 3.1CRITICAL 9.8
- TI-2025-15038 Out-of-bounds write in Samsung Mobile Devices KEVCVSS 3.1CRITICAL 9.8
- TI-2025-04133 Path traversal in Samsung MagicINFO 9 Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-06858 Path traversal in Samsung MagicINFO 9 Server KEVCVSS 3.1CRITICAL 9.8
- TI-2016-00916 Integer overflow in Adobe Flash Player before 18.0.0.333 and 19.x through 21.x before… KEVCVSS 3.1HIGH 8.8
- TI-2022-06595 An improper check or handling of exceptional conditions in NPU driver prior to SMR… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-21132 · CVE Program
- CVE-2026-21132 · NVD
- FIRST EPSS
- GHSA-6mm7-m528-46x8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences