Symlink policy bypass in ImageMagick IsRightsAuthorizedByName
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.
Summary
ImageMagick before 6.9.13-58 and from 7.0.0 before 7.1.2-33 does not properly account for symbolic links in its IsRightsAuthorizedByName policy check (CWE-59). A local user who can create a symlink can point it at a policy-restricted path and evade the configured policy. The attacker needs low privileges and a condition that is present but hard to meet, and the impact is limited to partial confidentiality and integrity.
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
Description from the CNA
ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 does not properly account for symbolic links in the IsRightsAuthorizedByName security policy check, allowing configured policy restrictions to be bypassed. Local attackers who can create a symlink can point it at a policy-restricted path to evade the configured policy.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ImageMagick | ImageMagick | 7.0.0 to before 7.1.2-33 | 7.1.2-33 | Patch available | CNA |
| ImageMagick | ImageMagick | before 6.9.13-58 | 6.9.13-58 | Patch available | CNA |
- ImageMagick VendorImageMagick Affected 7.0.0 to before 7.1.2-33 Fixed in 7.1.2-33 Patch available CNA
- ImageMagick VendorImageMagick Affected before 6.9.13-58 Fixed in 6.9.13-58 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* | before 6.9.13-58; 7.0.0-0 to before 7.1.2-33 | Vulnerable | ImageMagick |
- cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* Versions before 6.9.13-58; 7.0.0-0 to before 7.1.2-33 Vulnerable ·ImageMagick
Remediation
The fixed versions are ImageMagick 6.9.13-58 for the 6 branch and 7.1.2-33 for the 7 branch. Red Hat lists Red Hat Enterprise Linux 6 as affected with no fix planned and Red Hat Enterprise Linux 7 as affected with no fix available.
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
- Fix · CNA ImageMagick (ImageMagick) Fixed in 7.1.2-33
- Fix · CNA ImageMagick (ImageMagick) Fixed in 6.9.13-58
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-12 Threatist record created from CVE-2026-105081
- 2026-10-12 Alias added: GHSA-gx8j-c5hq-h6p7
- 2026-10-13 Affected versions changed · Red Hat
- 2026-10-13 CVSS score added · Red Hat
- 2026-10-13 CISA SSVC decision points changed
- 2026-10-29 Affected versions changed · CNA
- 2026-11-03 CVSS score added · NVD
References
More Imagemagick vulnerabilities
- TI-2016-03144 The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT… KEVCVSS 3.1HIGH 8.4
- TI-2023-16996 Improper input validation in ImageMagick CVSS 3.1CRITICAL 9.8
- TI-2016-03148 The (1) HTTP and (2) FTP coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1… KEVCVSS 3.1MEDIUM 5.5
- TI-2016-03145 The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote… KEVCVSS 3.1MEDIUM 5.5
- TI-2025-35690 ImageMagick BlobStream Forward-Seek Under-Allocation CVSS 3.1CRITICAL 9.8
- TI-2025-33094 ImageMagick has Stack Buffer Overflow in image.c CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-105081 · CVE Program
- CVE-2026-105081 · NVD
- FIRST EPSS
- GHSA-gx8j-c5hq-h6p7 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-105081 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences