Repeated opaque whiteouts exhaust CPU in containerd layer unpack
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
containerd versions before 1.7.35, from 2.0.0-beta.0 before 2.0.12, from 2.2.0 before 2.2.8, and from 2.3.0 before 2.3.5 are affected. The layer unpack handler repeatedly traverses directories for certain opaque whiteout configurations, which is an uncontrolled resource consumption flaw (CWE-400). A malicious image layer can trigger the repeated traversals when pulled or imported, consuming CPU, delaying container startup, and reducing image-pull concurrency for unrelated deployments.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
containerd is an open-source container runtime. Prior to 1.7.35, 2.0.12, 2.2.8, and 2.3.5, containerd's layer unpack handler repeatedly traverses directories for certain opaque whiteout configurations. A malicious image layer can trigger repeated directory traversals while opaque whiteouts are processed. Pulling or importing the image can consume CPU, delay container startup, and reduce image-pull concurrency for unrelated deployments. This issue is fixed in versions 1.7.35, 2.0.12, 2.2.8, and 2.3.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | containerd | before 1.7.35; 2.0.0-beta.0 to before 2.0.12; 2.2.0 to before 2.2.8; 2.3.0 to before 2.3.5 | 1.7.35, 2.0.12, 2.2.8, 2.3.5 | Patch available | CNA |
| — | github.com/containerd/containerd/v2 (Go) | before 2.0.12 | 2.0.12 | Patch available | GHSA-rp3h-jf77-q9p4 |
| — | github.com/containerd/containerd (Go) | before 1.7.35 | 1.7.35 | Patch available | GHSA-rp3h-jf77-q9p4 |
| — | github.com/containerd/containerd/v2 (Go) | 2.2.0 to before 2.2.8 | 2.2.8 | Patch available | GHSA-rp3h-jf77-q9p4 |
| — | github.com/containerd/containerd/v2 (Go) | 2.3.0 to before 2.3.5 | 2.3.5 | Patch available | GHSA-rp3h-jf77-q9p4 |
- containerd Vendorbackstage Affected before 1.7.35; 2.0.0-beta.0 to before 2.0.12; 2.2.0 to before 2.2.8; 2.3.0 to before 2.3.5 Fixed in 1.7.35, 2.0.12, 2.2.8, 2.3.5 Patch available CNA
- github.com/containerd/containerd/v2 (Go) Vendor— Affected before 2.0.12 Fixed in 2.0.12 Patch available GHSA-rp3h-jf77-q9p4
- github.com/containerd/containerd (Go) Vendor— Affected before 1.7.35 Fixed in 1.7.35 Patch available GHSA-rp3h-jf77-q9p4
- github.com/containerd/containerd/v2 (Go) Vendor— Affected 2.2.0 to before 2.2.8 Fixed in 2.2.8 Patch available GHSA-rp3h-jf77-q9p4
- github.com/containerd/containerd/v2 (Go) Vendor— Affected 2.3.0 to before 2.3.5 Fixed in 2.3.5 Patch available GHSA-rp3h-jf77-q9p4
Remediation
Upgrade containerd to 1.7.35, 2.0.12, 2.2.8, or 2.3.5, depending on the release branch in use.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA containerd (containerd) Fixed in 1.7.35, 2.0.12, 2.2.8, 2.3.5
- Fix · GHSA-rp3h-jf77-q9p4 github.com/containerd/containerd/v2 (Go) Fixed in 2.0.12 Advisory →
- Fix · GHSA-rp3h-jf77-q9p4 github.com/containerd/containerd (Go) Fixed in 1.7.35 Advisory →
- Fix · GHSA-rp3h-jf77-q9p4 github.com/containerd/containerd/v2 (Go) Fixed in 2.2.8 Advisory →
- Fix · GHSA-rp3h-jf77-q9p4 github.com/containerd/containerd/v2 (Go) Fixed in 2.3.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Hardened Images
Timeline
- 2026-10-12 Threatist record created from CVE-2026-95838
- 2026-10-13 CISA SSVC decision points changed
- 2026-10-16 Alias added: GHSA-rp3h-jf77-q9p4
- 2026-10-16 Fix available: Go/github.com/containerd/containerd/[email protected], Go/github.com/containerd/containerd/[email protected], Go/github.com/containerd/containerd/[email protected] +1 · GHSA-rp3h-jf77-q9p4
- 2026-10-16 CVSS score added · GHSA-rp3h-jf77-q9p4
- 2026-10-16 Weakness changed · GHSA-rp3h-jf77-q9p4
- 2026-10-16 4 new references · GHSA-rp3h-jf77-q9p4
- 2026-10-20 Affected versions changed · Red Hat
- 2026-10-20 CVSS score added · Red Hat
References
More backstage vulnerabilities
- TI-2026-33119 Malware in 42 @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys KEVCVSS 3.1CRITICAL 9.6
- TI-2018-10499 Integer overflow in backstage kernel KEVCVSS 3.0HIGH 7.8
- TI-2024-08998 Remote Code Execution in kedro-org/kedro CVSS 3.0CRITICAL 9.8
- TI-2023-12294 Dragonfly2 vulnerable to hard coded cyptographic key CVSS 3.1CRITICAL 9.8
- TI-2021-12074 Authentication vulnerability in MOSN v.0.23.0 allows attacker to escalate privileges via… CVSS 3.1CRITICAL 9.8
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
Sources
- CVE-2026-95838 · CVE Program
- CVE-2026-95838 · NVD
- FIRST EPSS
- GHSA-rp3h-jf77-q9p4 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-95838 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences