Missing authorization in Frappe ERPNext lets users modify documents
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
Frappe ERPNext from 0 before 15.121.1 and from 16.0.0-beta.1 before 16.34.2 has a missing authorization flaw (CWE-862) in certain endpoints that do not check permissions properly. An authenticated attacker can send requests to these endpoints to modify documents and data beyond what their assigned role permits.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Frappe ERPNext before 15.121.1 and 16.x before 16.34.2 contains a missing authorization vulnerability in certain endpoints that fail to enforce proper authorization checks. Authenticated attackers can send requests to these endpoints to modify documents and data beyond what their assigned role permits.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Frappe ERPNext to version 15.121.1 for the 15.x branch or to version 16.34.2 for the 16.x branch.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA erpnext (frappe) Fixed in 15.121.1, 16.34.2
Timeline
- 2026-10-13 Threatist record created from CVE-2026-109623
- 2026-10-13 Alias added: GHSA-j78v-2m92-3mmg
- 2026-10-13 CISA SSVC decision points changed
References
More frappe vulnerabilities
- TI-2026-28140 ERPNext v15.103.1 and before is vulnerable to Server-Side Template Injection (SSTI). CVSS 3.1CRITICAL 9.8
- TI-2025-40873 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40872 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40871 A Server-Side Template Injection (SSTI) vulnerability exists in the Frappe ERPNext… CVSS 3.1CRITICAL 9.8
- TI-2025-32462 In Frappe ERPNext 15.57.5, the function get_rfq_containing_supplier() at… CVSS 3.1HIGH 8.2
- TI-2025-32461 In Frappe ERPNext 15.57.5, the function get_stock_balance_for() at… CVSS 3.1HIGH 8.2
Sources
- CVE-2026-109623 · CVE Program
- CVE-2026-109623 · NVD
- FIRST EPSS
- GHSA-j78v-2m92-3mmg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences