Cross-site scripting in GitLab syntax-highlighted output
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
GitLab CE and EE from 19.1 before 19.2.8, from 19.3 before 19.3.5, and from 19.4 before 19.4.2 are affected. Improper sanitization of HTML attributes in syntax-highlighted output (CWE-79) lets an authenticated user run arbitrary JavaScript in other users' browser sessions through a specially crafted repository. The sources describe the attack as possible only under certain conditions, and the CVSS 3.1 vector requires user interaction and low privileges.
Written with Claude Haiku 5.5 from the sources below · 2026-10-27
Description from the CNA
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to execute arbitrary JavaScript in the context of other users' browser sessions via a specially crafted repository, due to improper sanitization of HTML attributes in syntax-highlighted output.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 19.1 to before 19.2.8; 19.3 to before 19.3.5; 19.4 to before 19.4.2 | 19.2.8, 19.3.5, 19.4.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 19.1 to before 19.2.8; 19.3 to before 19.3.5; 19.4 to before 19.4.2 Fixed in 19.2.8, 19.3.5, 19.4.2 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.1.0 to before 19.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.1.0 to before 19.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.3.0 to before 19.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.3.0 to before 19.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.4.0 to before 19.4.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.4.0 to before 19.4.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.1.0 to before 19.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.1.0 to before 19.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.3.0 to before 19.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.3.0 to before 19.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.4.0 to before 19.4.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.4.0 to before 19.4.2 Vulnerable ·GitLab
Remediation
Upgrade GitLab to 19.2.8, 19.3.5, or 19.4.2.
Written with Claude Haiku 5.5 from the sources below · 2026-10-27
- Fix · CNA GitLab (GitLab) Fixed in 19.2.8, 19.3.5, 19.4.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 19.2.8, 19.3.5, 19.4.2
23 records Highest priority Priority CRITICAL 1 CRITICAL, 1 MEDIUM, 21 LOW
Other records, highest priority first
- TI-2026-71508 Integer overflow in GitLab allows code execution on the serverPriority CRITICAL 100
- TI-2026-71475 Permissive regular expression in GitLab lets attackers poison cached filesPriority LOW 38
- TI-2026-71477 Incorrect authorization in GitLab lets developers run protected pipelinesPriority LOW 37
Timeline
- 2026-10-13 Threatist record created from CVE-2026-92883
- 2026-10-13 Alias added: GHSA-ggg2-vpmq-m78f
- 2026-10-13 Priority changed: MEDIUM → LOW
- 2026-10-15 CISA SSVC decision points changed
- 2026-10-25 Priority changed: LOW → MEDIUM
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-92883 · CVE Program
- CVE-2026-92883 · NVD
- FIRST EPSS
- GHSA-ggg2-vpmq-m78f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences