Improper input validation in NETGEAR RAX and CAX Block Sites feature
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
NETGEAR CAX30 before V2.3.4.12, RAX30 before V1.0.14.108, RAX5 before V1.0.5.34 and RAXE300 before V1.0.10.72 routers are affected. Insufficient input validation (CWE-20) in the Block Sites website blocking feature lets a network-adjacent attacker with network access, such as WiFi credentials, run unauthorized commands on the router. The flaw applies only when Block Sites is turned on.
Written with Claude Haiku 5.5 from the sources below · 2026-10-27
Description from the CNA
An insufficient input validation vulnerability in the website blocking feature (Block Sites) of the listed NETGEAR router models allows a network-adjacent attacker having network access (such as WiFi credentials) to run unauthorized commands on the router. This vulnerability could affect the confidentiality, integrity, and availability of the affected router. It applies only when the Block Sites feature is turned on.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NETGEAR | CAX30 | before V2.3.4.12 | V2.3.4.12 | Patch available | CNA |
| NETGEAR | RAX30 | before V1.0.14.108 | V1.0.14.108 | Patch available | CNA |
| NETGEAR | RAX5 | before V1.0.5.34 | V1.0.5.34 | Patch available | CNA |
| NETGEAR | RAXE300 | before V1.0.10.72 | V1.0.10.72 | Patch available | CNA |
- CAX30 VendorNETGEAR Affected before V2.3.4.12 Fixed in V2.3.4.12 Patch available CNA
- RAX30 VendorNETGEAR Affected before V1.0.14.108 Fixed in V1.0.14.108 Patch available CNA
- RAX5 VendorNETGEAR Affected before V1.0.5.34 Fixed in V1.0.5.34 Patch available CNA
- RAXE300 VendorNETGEAR Affected before V1.0.10.72 Fixed in V1.0.10.72 Patch available CNA
Remediation
Fixed versions are V2.3.4.12 for CAX30, V1.0.14.108 for RAX30, V1.0.5.34 for RAX5 and V1.0.10.72 for RAXE300.
Written with Claude Haiku 5.5 from the sources below · 2026-10-27
- Fix · CNA CAX30 (NETGEAR) Fixed in V2.3.4.12
- Fix · CNA RAX30 (NETGEAR) Fixed in V1.0.14.108
- Fix · CNA RAX5 (NETGEAR) Fixed in V1.0.5.34
- Fix · CNA RAXE300 (NETGEAR) Fixed in V1.0.10.72
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
NETGEAR RAX30 — kb.netgear.com/000070958/October-2026-NETGEAR-Security-Advi…
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-71755 Authentication bypass in certain NETGEAR RAX series modelsPriority LOW 30
Timeline
- 2026-10-13 Threatist record created from CVE-2026-11732
- 2026-10-13 Alias added: GHSA-xj6r-rgc9-w4p7
- 2026-10-13 CVSS score changed · CNA
- 2026-10-14 CISA SSVC decision points changed
- 2026-10-16 1 new reference · CNA
References
More NETGEAR vulnerabilities
- TI-2020-16346 NETGEAR JGS516PE devices before 2.6.0.43 are affected by lack of access control at the function level. KEVCVSS 3.1CRITICAL 9.8
- TI-2017-04600 Buffer overflow in NETGEAR All versions prior to WNR2000v3 1.1.2.14, WNR2000v4 1.0.0.66… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03982 ping.cgi on NETGEAR DGN2200 devices with firmware through 10.0.0.50 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08250 The NETGEAR WNR2000v5 router contains a buffer overflow in the hidden_lang_avi parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-01416 (1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-04162 dnslookup.cgi on NETGEAR DGN2200 devices with firmware through 10.0.0.50 allows remote… KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2026-11732 · CVE Program
- CVE-2026-11732 · NVD
- FIRST EPSS
- GHSA-xj6r-rgc9-w4p7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences